summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-28 06:46:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-28 07:05:33 +0100
commit5baa0707b78106ed51dc28ff70cdbb4a90159dfb (patch)
treec1d2370fd8ea6ff99beb3e0739a0f3b0b5a4791d /dev-python/pytest-xprocess
parentdev-python/lmfit: Bump to 1.1.0 (diff)
downloadgentoo-5baa0707b78106ed51dc28ff70cdbb4a90159dfb.tar.gz
gentoo-5baa0707b78106ed51dc28ff70cdbb4a90159dfb.tar.bz2
gentoo-5baa0707b78106ed51dc28ff70cdbb4a90159dfb.zip
dev-python/pytest-xprocess: Bump to 0.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xprocess')
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index 1b576776f5a8..8b4a717525f2 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1 +1,2 @@
DIST pytest-xprocess-0.20.0.tar.gz 30342 BLAKE2B 8e66ad321224cb8e702721b0936c56b65be5aee9330a233c710519303679f2d1eea03825fe4326ffd2811f6fe4c37db217a2c0c34561742bd2c849ddcae7284e SHA512 bce022c924db94f53549c1df5547a8df7390806bb99d817f152f1e5fb946fef60f2447a31dc519577c1b54d6a7adeb7d7d996a28e7784918622db5ccfd0b035b
+DIST pytest-xprocess-0.21.0.tar.gz 30601 BLAKE2B c487b6223306c8a96ea2c4f99763ab8e59ea1db908b2ed93280fa3e2805794798b4555c3d07c730f911702712371bb390780709caa9eb6663451367f58b9781c SHA512 72f8db45a11cffb65302379c1690ef5ad9d71a1aa40b7fd03e1231f7ad0c0413638f7d2155f5b366d2d623399512759d8ffdac8591eb24b77562f9b1f584ed74
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild
new file mode 100644
index 000000000000..07a1ee622918
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.21.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest