summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-13 23:19:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-14 16:58:23 +0300
commit393b8cf31c1b79b3c923413b9661d40df7c8f828 (patch)
treef8969f0be50bea87e5bda2c39173fe8d33fb1ab5 /dev-python/pytest-xvfb
parentdev-python/pytest-xvfb: add github upstream metadata (diff)
downloadgentoo-393b8cf31c1b79b3c923413b9661d40df7c8f828.tar.gz
gentoo-393b8cf31c1b79b3c923413b9661d40df7c8f828.tar.bz2
gentoo-393b8cf31c1b79b3c923413b9661d40df7c8f828.zip
dev-python/pytest-xvfb: enable py3.10, cleanup python_test
Closes: https://github.com/gentoo/gentoo/pull/22284 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild
index dd8953d8bdb8..efd50e3c0ec1 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_REQ_USE="tk"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -22,13 +22,4 @@ RDEPEND="
x11-base/xorg-server[xvfb]
"
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTHONPATH="${BUILD_DIR}/install/lib"
- esetup.py install \
- --root="${BUILD_DIR}/install" \
- --install-lib=lib
-
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests --install pytest