summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-16 10:26:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-16 11:26:44 +0200
commit0da652db040029f8d46cf2355dc4a6924164f432 (patch)
treeefc1ce7c72286285a4eb1fa982e38d39ce9bec75 /dev-python/pytest
parentgames-simulation/openttd: Added live ebuild. (diff)
downloadgentoo-0da652db040029f8d46cf2355dc4a6924164f432.tar.gz
gentoo-0da652db040029f8d46cf2355dc4a6924164f432.tar.bz2
gentoo-0da652db040029f8d46cf2355dc4a6924164f432.zip
dev-python/pytest: Bump to 3.6.3
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/files/pytest-3.6.3-pypy-syntaxerror-offset.patch29
-rw-r--r--dev-python/pytest/pytest-3.6.3.ebuild85
3 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index f7b0898a6e27..0f9eee021dc9 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -2,3 +2,4 @@ DIST pytest-3.0.3.tar.gz 731934 BLAKE2B 7fb57d75bd54eb8a31d9701fdf739119715c475e
DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e74655f7b4cb08ec421651f987597021a31471aab5a32d637b99620ce7792cbdf8f85561db3bb10ff06a446ba1 SHA512 6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db
DIST pytest-3.4.1.tar.gz 812928 BLAKE2B 27b25fcc5a268b1c92188c01bf16bf1eb4b8ced7d1a3c8095350ec55b1f1845a5d54bd6bd169142ca0d327f2f8d193774643174a356dd95fa07b3195bc1e8713 SHA512 75f728840cde6512619a03ce75fd0b04cb9d57a99f381366a0f9c10ffa3210448e7e85505357bfa9bfb0cca11cdedda2c0e091e5473ed82707a2597f234e659a
DIST pytest-3.4.2.tar.gz 812719 BLAKE2B 96623d6cdea4bd79778175c18c949938505f1862010f700f9a8cb85f445910381af391a5b69e664fbbfc254bf46502c798c72026772070236a0a3bca7aeeb3d6 SHA512 787065ab76d4482799bb2da9f024c9c383e68cc1cc01f3b80f6ed9444ca6383d20953615696ed4dd01668777b094cf5002b23c4ce51828879dcf8ebf2170c71b
+DIST pytest-3.6.3.tar.gz 830949 BLAKE2B 4c0df5d157b8bb0ac6261a793aac2a8074c869b1a7cbda3eda600c79648b3722eaf2a57514c1fece60e0aac324b8ed09e8e889dda268619204e9e1f1637e1c9b SHA512 e18d8e972cb1b05b037b9441eea5981ce036d8e2c2bab80f6e50f283df9bd08740296133990424cf78449f6d3d2fbd1d59709770aa972af99fe061583f2d79a7
diff --git a/dev-python/pytest/files/pytest-3.6.3-pypy-syntaxerror-offset.patch b/dev-python/pytest/files/pytest-3.6.3-pypy-syntaxerror-offset.patch
new file mode 100644
index 000000000000..31dd00546761
--- /dev/null
+++ b/dev-python/pytest/files/pytest-3.6.3-pypy-syntaxerror-offset.patch
@@ -0,0 +1,29 @@
+https://salsa.debian.org/python-team/modules/pytest/commit/405c05a0827592515de76e23c94de1f7773273e6.patch
+
+(updated by mgorny for 3.6.3 -- upstream quoting changes)
+
+From 405c05a0827592515de76e23c94de1f7773273e6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ond=C5=99ej=20Nov=C3=BD?= <onovy@debian.org>
+Date: Thu, 10 May 2018 11:42:56 +0200
+Subject: [PATCH] Fix PyPy SyntaxError offset in tests
+
+---
+ testing/code/test_source.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testing/code/test_source.py b/testing/code/test_source.py
+index fcce3fa..22278d8 100644
+--- a/testing/code/test_source.py
++++ b/testing/code/test_source.py
+@@ -117,7 +117,7 @@ def test_source_strip_multiline():
+ def test_syntaxerror_rerepresentation():
+ ex = pytest.raises(SyntaxError, _pytest._code.compile, "xyz xyz")
+ assert ex.value.lineno == 1
+- assert ex.value.offset in (4, 7) # XXX pypy/jython versus cpython?
++ assert ex.value.offset in (4, 5, 7) # XXX pypy/jython versus cpython?
+ assert ex.value.text.strip(), "x x"
+
+
+--
+2.18.0
+
diff --git a/dev-python/pytest/pytest-3.6.3.ebuild b/dev-python/pytest/pytest-3.6.3.ebuild
new file mode 100644
index 000000000000..fcf42f682c5b
--- /dev/null
+++ b/dev-python/pytest/pytest-3.6.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+# doc apparently requires sphinxcontrib_trio, not yet packaged
+IUSE="test" # doc
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+COMMON_DEPEND="
+ >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.2.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.5[${PYTHON_USEDEP}]
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# doc? (
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/sphinx[${PYTHON_USEDEP}]
+# )"
+
+# flake & pytest-capturelog cause a number of tests to fail
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.22.2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ !!dev-python/pytest-capturelog
+ )"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ !<dev-python/logilab-common-1.3.0"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/pytest-3.6.3-pypy-syntaxerror-offset.patch
+ )
+
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ # those tests appear to hang with python3.5+; TODO: investigate why
+ sed -i -e 's:test_runtest_location_shown_before_test_starts:_&:' \
+ testing/test_terminal.py || die
+ sed -i -e 's:test_trial_pdb:_&:' testing/test_unittest.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ -vv testing || die "tests failed with ${EPYTHON}"
+}
+
+#python_compile_all() {
+# use doc && emake -C doc/en html
+#}
+#
+#python_install_all() {
+# use doc && HTML_DOCS=( doc/en/_build/html/. )
+# distutils-r1_python_install_all
+#}