summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-09-10 15:49:36 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-09-10 15:51:29 -0400
commit68f0a863ac462cfd882825a186cf41e16ec85484 (patch)
tree292ec0ebd4097220fc9448a53e457e1fd223e2bf /dev-python/pytest
parentmedia-sound/pnmixer: Drop old (diff)
downloadgentoo-68f0a863ac462cfd882825a186cf41e16ec85484.tar.gz
gentoo-68f0a863ac462cfd882825a186cf41e16ec85484.tar.bz2
gentoo-68f0a863ac462cfd882825a186cf41e16ec85484.zip
dev-python/pytest: bump to 3.8.0
Need to drop ~ia64 and ~amd64-fbsd because of new dev-python/pathlib2 dependency. Will rekeyword in existing 3.6.3 keywording bug. Bug: https://bugs.gentoo.org/661306 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-3.8.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 0f9eee021dc9..7529890c8910 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -3,3 +3,4 @@ DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e7
DIST pytest-3.4.1.tar.gz 812928 BLAKE2B 27b25fcc5a268b1c92188c01bf16bf1eb4b8ced7d1a3c8095350ec55b1f1845a5d54bd6bd169142ca0d327f2f8d193774643174a356dd95fa07b3195bc1e8713 SHA512 75f728840cde6512619a03ce75fd0b04cb9d57a99f381366a0f9c10ffa3210448e7e85505357bfa9bfb0cca11cdedda2c0e091e5473ed82707a2597f234e659a
DIST pytest-3.4.2.tar.gz 812719 BLAKE2B 96623d6cdea4bd79778175c18c949938505f1862010f700f9a8cb85f445910381af391a5b69e664fbbfc254bf46502c798c72026772070236a0a3bca7aeeb3d6 SHA512 787065ab76d4482799bb2da9f024c9c383e68cc1cc01f3b80f6ed9444ca6383d20953615696ed4dd01668777b094cf5002b23c4ce51828879dcf8ebf2170c71b
DIST pytest-3.6.3.tar.gz 830949 BLAKE2B 4c0df5d157b8bb0ac6261a793aac2a8074c869b1a7cbda3eda600c79648b3722eaf2a57514c1fece60e0aac324b8ed09e8e889dda268619204e9e1f1637e1c9b SHA512 e18d8e972cb1b05b037b9441eea5981ce036d8e2c2bab80f6e50f283df9bd08740296133990424cf78449f6d3d2fbd1d59709770aa972af99fe061583f2d79a7
+DIST pytest-3.8.0.tar.gz 865922 BLAKE2B 821051de2c502c892841f59124f6cdbfb6f31ebd8661bf242484c7c3f687ce75f9c4eb0984f7dabed0aff44277dcbbeb9f14c4cde2f6b152aad69f3769e27bc8 SHA512 26efe2bcd6c86c55cb17a17ad3cfe0762ba5d61adf9830fe5780c0c90df65bbeb2346abb8310c6123c308ed0e641d4cf325ca9ac16dcd8994b6a636bcfd386a4
diff --git a/dev-python/pytest/pytest-3.8.0.ebuild b/dev-python/pytest/pytest-3.8.0.ebuild
new file mode 100644
index 000000000000..1ed99d6919ca
--- /dev/null
+++ b/dev-python/pytest/pytest-3.8.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+# doc apparently requires sphinxcontrib_trio, not yet packaged
+IUSE="test" # doc
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+COMMON_DEPEND="
+ >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7 python3_{4,5} )
+ >=dev-python/pluggy-0.7[${PYTHON_USEDEP}]
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# doc? (
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/sphinx[${PYTHON_USEDEP}]
+# )"
+
+# flake & pytest-capturelog cause a number of tests to fail
+DEPEND="${COMMON_DEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.22.2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ !!dev-python/pytest-capturelog
+ )"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ !<dev-python/logilab-common-1.3.0"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/pytest-3.6.3-pypy-syntaxerror-offset.patch
+ )
+
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ # those tests appear to hang with python3.5+; TODO: investigate why
+ sed -i -e 's:test_runtest_location_shown_before_test_starts:_&:' \
+ testing/test_terminal.py || die
+ sed -i -e 's:test_trial_pdb:_&:' testing/test_unittest.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ -vv testing || die "tests failed with ${EPYTHON}"
+}
+
+#python_compile_all() {
+# use doc && emake -C doc/en html
+#}
+#
+#python_install_all() {
+# use doc && HTML_DOCS=( doc/en/_build/html/. )
+# distutils-r1_python_install_all
+#}