summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-11 19:43:21 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-12 00:11:20 +0200
commit7b2ed36e6ad5a93e9518d164d5f90364f4812a5b (patch)
tree8762a35a2d3ebf12860d761e34ca35471b0be751 /dev-python/pytest
parentdev-python/pytest: Disable hanging py3.5+ tests (diff)
downloadgentoo-7b2ed36e6ad5a93e9518d164d5f90364f4812a5b.tar.gz
gentoo-7b2ed36e6ad5a93e9518d164d5f90364f4812a5b.tar.bz2
gentoo-7b2ed36e6ad5a93e9518d164d5f90364f4812a5b.zip
dev-python/pytest: Kill obsolete pypy3 workaround
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-3.4.2.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/pytest/pytest-3.4.2.ebuild b/dev-python/pytest/pytest-3.4.2.ebuild
index ed3fc47c722f..122e1393e02a 100644
--- a/dev-python/pytest/pytest-3.4.2.ebuild
+++ b/dev-python/pytest/pytest-3.4.2.ebuild
@@ -73,14 +73,8 @@ python_prepare_all() {
}
python_test() {
- # test_nose.py not written to suit py3.2 in pypy3
- if [[ "${EPYTHON}" == pypy3 ]]; then
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX -vv \
- --ignore=testing/BUILD_nose.py \
- || die "tests failed with ${EPYTHON}"
- else
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX -vv testing || die "tests failed with ${EPYTHON}"
- fi
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ -vv testing || die "tests failed with ${EPYTHON}"
}
python_compile_all(){