summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 07:31:08 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 08:06:22 +0100
commitcc1c5fc14a822c82f139883b3505daf9240dc95e (patch)
treeb662a1f43ae89cc7e9786855fe353a5bee6a24c8 /dev-python/pytest
parentdev-python/configargparse: Bump to 1.1 (diff)
downloadgentoo-cc1c5fc14a822c82f139883b3505daf9240dc95e.tar.gz
gentoo-cc1c5fc14a822c82f139883b3505daf9240dc95e.tar.bz2
gentoo-cc1c5fc14a822c82f139883b3505daf9240dc95e.zip
dev-python/pytest: Bump to 5.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-5.4.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 93b3686d095b..269039c94178 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -3,3 +3,4 @@ DIST pytest-4.5.0.tar.gz 943607 BLAKE2B 49a0e91fda7f4231fdd39f90eb2daa344d3034c1
DIST pytest-4.6.9.tar.gz 956816 BLAKE2B 7eaeaa0d47c17836a35d9cdc97663f8ef65253099b21d60a7ffc3655d8bd93c6b4e33045caa6c8ab9bb8b920b93e596ba86d8eac4ab07b3b7a5989b38312f4fc SHA512 ab45a8662aa798a6ae224ad2cd68e043c605e4830c76cb6c6aca3cfccef232c024cbbb6c48c9bae19148099c339abfef3270a2208cc7e5c37a10b34b0aa6ba79
DIST pytest-5.3.4.tar.gz 990897 BLAKE2B dd6f0a277352dd72e6348e89813a7df50aabf9ee134afd69412100b87a7898128ec6b17bf29082c88554b66ba5622b7e0b9a1338d6b740795f33055a9279cfdc SHA512 562966d74d2ff12715ececa46acdd49de67f5e792687d52b3f53589f6dc6105aed09bd4c5098989d70b8a69e6bb4cfb9c0b1ee7e9cfc8e8252e3ba6b4d39e4bc
DIST pytest-5.3.5.tar.gz 990935 BLAKE2B 257628ca9bf7b5e17eb54d868f37fc18a6cc43e66e7ec64581aae0faa8c92a9aa102f011e3117f6c669fc3dfa27fb884c2fefea6b0771fa0ed8999364bc4e149 SHA512 14877d67aef83d498c8a2917b9633bda317948fa889100e6d1a00547a71f0bfb32d8a01506e97bab6372bfbae17a03aa21bdad8d81072a163a5c9c042498a3b3
+DIST pytest-5.4.1.tar.gz 1017924 BLAKE2B 2892b06655384c8453963e8444e7c1659f4ce60410afe6d01c480da4858628f6c8fd8774131c5bfaca3b3baf9936e3e4d607788b390d37f7aee90cb39c4ba15c SHA512 50d94158817561316cfb4c6ad4481858a76cfe44ba964cc7a3bb81d3701eb621ca5cd46c4be24644134417d8bf7e7771f4b3a30af71fde5ea9705c3241fa2878
diff --git a/dev-python/pytest/pytest-5.4.1.ebuild b/dev-python/pytest/pytest-5.4.1.ebuild
new file mode 100644
index 000000000000..34b5e22d889c
--- /dev/null
+++ b/dev-python/pytest/pytest-5.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# flake cause a number of tests to fail
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-4.5.0-strip-setuptools_scm.patch
+)
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}