summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-08 02:08:53 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-08 19:40:13 +0200
commit88e15ca569901bc9861797be475e96b7d7f6e147 (patch)
tree1b7267c5d707289d1684c9181a7a17bc4d30c2a5 /dev-python/python-application
parentmedia-video/gxine: Bump to version 0.5.908 (diff)
downloadgentoo-88e15ca569901bc9861797be475e96b7d7f6e147.tar.gz
gentoo-88e15ca569901bc9861797be475e96b7d7f6e147.tar.bz2
gentoo-88e15ca569901bc9861797be475e96b7d7f6e147.zip
dev-python/python-application: initial import of version 1.5.0
Gentoo-Bug: 446026
Diffstat (limited to 'dev-python/python-application')
-rw-r--r--dev-python/python-application/Manifest1
-rw-r--r--dev-python/python-application/metadata.xml30
-rw-r--r--dev-python/python-application/python-application-1.5.0.ebuild19
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-application/Manifest b/dev-python/python-application/Manifest
new file mode 100644
index 000000000000..eda074bffdc6
--- /dev/null
+++ b/dev-python/python-application/Manifest
@@ -0,0 +1 @@
+DIST python-application-1.5.0.tar.gz 43552 SHA256 9bc00c2c639bf633e2c5e08d4bf1bb5d7edaad6ccdd473692f0362df08f8aafc SHA512 9bf683a88bfb11ab5cf86b2d1ef86e22cf6fcb6004f0059b1d3cb2e1cde46827ced57a1cdd313c1d48dbd1ad610e9d36617619f79af748c55c517089720cb2b1 WHIRLPOOL 321411f6f33d29f2847accc805c78bbca3dc255e4768954d75904cea7f3843d2ff15f51bcc62706d8b6101b61d5e9d294968e607ff63f22a75982b00e8850f3a
diff --git a/dev-python/python-application/metadata.xml b/dev-python/python-application/metadata.xml
new file mode 100644
index 000000000000..91adab3be3ef
--- /dev/null
+++ b/dev-python/python-application/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package is a collection of modules that are useful when
+ building python applications. Their purpose is to eliminate the
+ need to divert resources into implementing the small tasks that
+ every application needs to do in order to run successfully and
+ focus instead on the application logic itself.
+
+ The modules that the application package provides are:
+ 1. process - UNIX process and signal management.
+ 2. python - python utility classes and functions.
+ 3. configuration - a simple interface to handle configuration files.
+ 4. log - an extensible system logger for console and syslog.
+ 5. debug - memory troubleshooting and execution timing.
+ 6. system - interaction with the underlying operating system.
+ 7. notification - an application wide notification system.
+ 8. version - manage version numbers for applications and packages.
+ 9. dependency - verify package dependencies at runtime.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-application</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-application/python-application-1.5.0.ebuild b/dev-python/python-application/python-application-1.5.0.ebuild
new file mode 100644
index 000000000000..23a3e8bf5e29
--- /dev/null
+++ b/dev-python/python-application/python-application-1.5.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Basic building blocks for python applications"
+HOMEPAGE="http://ag-projects.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"