summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-augeas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-augeas')
-rw-r--r--dev-python/python-augeas/Manifest3
-rw-r--r--dev-python/python-augeas/metadata.xml10
-rw-r--r--dev-python/python-augeas/python-augeas-0.4.1.ebuild28
-rw-r--r--dev-python/python-augeas/python-augeas-0.4.2_pre131218.ebuild29
-rw-r--r--dev-python/python-augeas/python-augeas-0.5.0.ebuild28
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/python-augeas/Manifest b/dev-python/python-augeas/Manifest
new file mode 100644
index 000000000000..47d3353da96e
--- /dev/null
+++ b/dev-python/python-augeas/Manifest
@@ -0,0 +1,3 @@
+DIST python-augeas-0.4.1.tar.gz 89652 SHA256 2d9e618fad03f68033b5ac94d0d57136df9ed75bf21c6e7877d3107866af89bf SHA512 ccd6ea10f927f06eba74dd48c21c7ca9a99c2910741ef925f078c09cd8a3421e63de3b74df2903a2cfd17f3defaa8df4624c9743d20e13bb5bfeacd7d50c5938 WHIRLPOOL bdb389691d85b259f0dba50205f99efa48ccec1676b48b2df2a7180079d1b3a91bd59f1020adbfe0088e7a5912fad6a0313d8c65cfb785fcbea87914d2676aec
+DIST python-augeas-0.4.2_pre131218.tar.xz 77636 SHA256 1ef4547c48e8ea155a1fd9908fc6b8e4d9bdfd9d51aa79488352de4ef3d40f50 SHA512 3677dfa4d7b6bbb22009ebee4ed4b46e50f7e5712354f5061476d5d21c86b956c4408f5ca005b674ad0e14e26c970830572aa077af6bb594dbff116991676e86 WHIRLPOOL 8bd303ce00811a2c686ccb840cb445eaa35e47888f5a53599e49d848020201adfe0a17b37137817d1cafd05d61b0783e6a65bb989bfb7195ec59d6c7eb438046
+DIST python-augeas-0.5.0.tar.gz 90667 SHA256 67d59d66cdba8d624e0389b87b2a83a176f21f16a87553b50f5703b23f29bac2 SHA512 d93d9e21c720084ee3c1841a2172dd1a4cfb41e668de0f557bd214efd65e685a1e5fc713a7d34e0fed727fe908bb1e8a09a1c10587bc27f3708cbcdee575cc51 WHIRLPOOL 155417cb5c03f581101b525d1b5e89ed9f28e9e145fa548061d36a9fe23791cb38422219695d2bd177aaa78989dfb363fd2023a2ec857456e18639bfdf93ee34
diff --git a/dev-python/python-augeas/metadata.xml b/dev-python/python-augeas/metadata.xml
new file mode 100644
index 000000000000..4c1aa3df62dd
--- /dev/null
+++ b/dev-python/python-augeas/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+python-augeas is a set of Python bindings around augeas.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-augeas/python-augeas-0.4.1.ebuild b/dev-python/python-augeas/python-augeas-0.4.1.ebuild
new file mode 100644
index 000000000000..574bf2ff4ba3
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-admin/augeas"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README.txt PKG-INFO"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test_augeas.py || die
+}
diff --git a/dev-python/python-augeas/python-augeas-0.4.2_pre131218.ebuild b/dev-python/python-augeas/python-augeas-0.4.2_pre131218.ebuild
new file mode 100644
index 000000000000..60cb00cd6856
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-0.4.2_pre131218.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+#SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-admin/augeas"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README.txt"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test_augeas.py || die
+}
diff --git a/dev-python/python-augeas/python-augeas-0.5.0.ebuild b/dev-python/python-augeas/python-augeas-0.5.0.ebuild
new file mode 100644
index 000000000000..a51b44d0d3d2
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-admin/augeas"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README.txt"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test_augeas.py || die
+}