summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-17 09:29:01 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-17 09:29:01 +0300
commitebd68ecf9d5d980241e7f6b09e899b04ceaf99df (patch)
tree471899717472d68c4f57c79048fc3345b21dc6d5 /dev-python/python-augeas
parentdev-python/python-discid: enable py3.11 (diff)
downloadgentoo-ebd68ecf9d5d980241e7f6b09e899b04ceaf99df.tar.gz
gentoo-ebd68ecf9d5d980241e7f6b09e899b04ceaf99df.tar.bz2
gentoo-ebd68ecf9d5d980241e7f6b09e899b04ceaf99df.zip
dev-python/python-augeas: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-augeas')
-rw-r--r--dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild b/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..a0fc746e68df
--- /dev/null
+++ b/dev-python/python-augeas/python-augeas-1.1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ app-admin/augeas
+ >=dev-python/cffi-1.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/remove-tests.patch" )
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" test_augeas.py || die "Tests failed with ${EPYTHON}"
+}