summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-28 07:06:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-28 07:31:51 +0200
commit48fe974e94acda51f111a302f04d6a75dd0efc8e (patch)
treec1e47db6467837d6e7926d12f62c889103ed0ac7 /dev-python/python-bugzilla
parentdev-python/google-auth: Bump to 1.34.0 (diff)
downloadgentoo-48fe974e94acda51f111a302f04d6a75dd0efc8e.tar.gz
gentoo-48fe974e94acda51f111a302f04d6a75dd0efc8e.tar.bz2
gentoo-48fe974e94acda51f111a302f04d6a75dd0efc8e.zip
dev-python/python-bugzilla: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index dfe666214717..d3cb037f7c7c 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1 +1,2 @@
DIST python-bugzilla-3.0.2.tar.gz 115324 BLAKE2B 3f64af96bf61d16e720338055391b187f53a968488535e76a5d6e56817030fc1c45f824ed27424b3e7440dc03759e77bcb8d417fa2278aa611b995bea2775f7a SHA512 c4fb79c9ca4d813a5dd9573e9a300aa01ea713fa11d43e2ee7ca13efb4720fed14fff339e9cc1b756505f43348768f0fdaaa8ae0b370640ff70e402f852e9b1a
+DIST python-bugzilla-3.1.0.tar.gz 115259 BLAKE2B d3eed35aeb9778e23266fb3ce1fc477a93c09533c78e478292b90cd49668f2627d7ef47afd46973898b4d5de474399aae5e94e5cd776d5608d32325dc826c12c SHA512 8f95a60e559cc5b4576d81f37c7104d6bd4afae21986db3c5ef05c6021e601690a01ca97d67fa37e97026f0b97762594e8edd0454953e31930fa841696f65121
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
new file mode 100644
index 000000000000..137bbf61ee25
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest