summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-04 20:44:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-04 20:53:31 +0200
commit81e3e217b009d2738d3a3540252bfb7306e4742f (patch)
tree8867507c7be7548a00110b098dddaa562f23ddd3 /dev-python/python-bugzilla
parentsys-block/fio: 3.20 fix gcc fno-common issue (diff)
downloadgentoo-81e3e217b009d2738d3a3540252bfb7306e4742f.tar.gz
gentoo-81e3e217b009d2738d3a3540252bfb7306e4742f.tar.bz2
gentoo-81e3e217b009d2738d3a3540252bfb7306e4742f.zip
dev-python/python-bugzilla: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-bugzilla')
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-2.5.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index 7b85b75efb38..94db4d8e6dbd 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1,3 +1,4 @@
DIST python-bugzilla-2.1.0.tar.gz 78791 BLAKE2B 31819e04ea5627b5513c22e9cb963cdea4d1ef8d6d4db78d14bf08b8b5fb373afaad4bddb2bc0b05d4637f966bf8b4f3699ace58ceff8ea226d9ffd4aacc7f61 SHA512 40dd331e2dbb4d70ce6d356eb800d6242ef9878112310087761c8dccb7f05b259f0f5fdee6821713a84c68f1e5f9e0bb6ee45542bc385f00822b97344371239e
DIST python-bugzilla-2.3.0.tar.gz 79002 BLAKE2B d3aaeaebf25bd56286fa1c4adcbf154ff2d84a28918bd1fd80e1f83b30bfe0f54f7418c75afc446c60046d69cf4ff6219718434158ce9cf040b0b2f7b94136ec SHA512 cd6e1c3f142ad74b8165fdd503ebaeb5e512ad8055dfc1e47e794908ac21cece6e39365544b94c123067f1d6527b65765431f2656336086e6dda940e446b763b
DIST python-bugzilla-2.4.0.tar.gz 109556 BLAKE2B cf2c7a5a0f491e92c484f2270ab6c8cf67e4ea87419000474ee8ca80e2b406a837d699915fd3c76f62dd79e4338a7276e88ed653fd0d81efcefba5e259559129 SHA512 cbe1d735d4a733eb91d5c6f278a1b7c23a0b142a515eb8a4efed1bf0446a692afa9780f6bfd99e21a079cd4921c4b11d20f65596886b2eba3ba08abdc8593515
+DIST python-bugzilla-2.5.0.tar.gz 110931 BLAKE2B e7a4dc0ee00abd4bd4c55aafac8a8d2902ade116b9f35d881c3ea07441b340dc247405951b5437545720c1742f54aae3c28fe64f93191a4d7f178a3cd2db7a0e SHA512 a840db5790a7f45cdcf6ef9e261d86c6b930db30ab6340a1f351b3fd32f32e4d0f6afb68af9befef5d4e84969d568471c5c236be047f6dbab52534af3570a244
diff --git a/dev-python/python-bugzilla/python-bugzilla-2.5.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-2.5.0.ebuild
new file mode 100644
index 000000000000..4b57c486410d
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-2.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest