summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-31 16:22:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-31 16:25:26 +0300
commit2ceefc89aa2e5fbd45fcaa3eec4cb33078760188 (patch)
treebb35e825aca9551f3713e28c250e7cba766e3abf /dev-python/python-cinderclient
parentdev-python/python-glanceclient: enable py3.9, enable tests (diff)
downloadgentoo-2ceefc89aa2e5fbd45fcaa3eec4cb33078760188.tar.gz
gentoo-2ceefc89aa2e5fbd45fcaa3eec4cb33078760188.tar.bz2
gentoo-2ceefc89aa2e5fbd45fcaa3eec4cb33078760188.zip
dev-python/python-cinderclient: add 8.0.0, enable py3.9, enable tests
Closes: https://bugs.gentoo.org/798357 Closes: https://bugs.gentoo.org/798354 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest1
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-8.0.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 958398611099..cef824b12b5c 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1 +1,2 @@
DIST python-cinderclient-7.2.1.tar.gz 251082 BLAKE2B 20b1ae9ecce0161e225b510363be74f7197075bd2247d3f5386894040582a61379faa1825197728bf9981fb9c6d66cc020483a07c0781e30e43f6bdadcb33185 SHA512 c434a353185d8e47d5849f08e7c9418454a5f643292837f0890f9aaccbf939be4528ae75851164068a2bc2ea39a4c841965be664bae4e7d37fec54a55c8332dc
+DIST python-cinderclient-8.0.0.tar.gz 236611 BLAKE2B 818279d06b597a00a66c34cf3b468e8293aaf1e90fd04c996e118ea206d475e598d7c8b9ca78542bd07ada1db5d7a2c7ea9a3748fe85ad787d283c8d8073ecc6 SHA512 ae0c5e1d6f0c173382f57f95ac05ec8872a8ed548b145c1f91d96ab7b9e4602cba11a7205c26c81027ca4ad07cbb69f675244e3606ae5dca00c22eeb8bedc126
diff --git a/dev-python/python-cinderclient/python-cinderclient-8.0.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-8.0.0.ebuild
new file mode 100644
index 000000000000..eaea356ea16e
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-8.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m stestr run --debug || die "Tests failed with ${EPYTHON}"
+}