summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-24 14:08:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-05-25 08:00:38 +0000
commit46204861ef6f910c6ff1055171495b2d2e7d3a24 (patch)
treee1a889f305e54147c468edaa46871798bc4da3d4 /dev-python/python-ctags
parentdev-python/python-ctags: fix metadata, use new upstream (diff)
downloadgentoo-46204861ef6f910c6ff1055171495b2d2e7d3a24.tar.gz
gentoo-46204861ef6f910c6ff1055171495b2d2e7d3a24.tar.bz2
gentoo-46204861ef6f910c6ff1055171495b2d2e7d3a24.zip
dev-python/python-ctags: bump to 1.2.3, add py3 support, tests
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1529 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/python-ctags')
-rw-r--r--dev-python/python-ctags/Manifest1
-rw-r--r--dev-python/python-ctags/python-ctags-1.2.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-ctags/Manifest b/dev-python/python-ctags/Manifest
index ec3804604266..2e1a9949625e 100644
--- a/dev-python/python-ctags/Manifest
+++ b/dev-python/python-ctags/Manifest
@@ -1 +1,2 @@
DIST python-ctags-1.0.6.tar.gz 24275 SHA256 16a3fe367360167dc62fd2dc4a262659c6c1a7454aac95eb491edc44345ed565 SHA512 d26663fbb216843b6a3417bc28e89a1cb8666d7ed6aab3d05e87ac2be1edac111b7a3f3d487b42d33d25f4ed984c76933991c40a4c946ac7710b4a55c781563b WHIRLPOOL e369048183735302b81e2d33ffd183e2e8cfed7019741dfecacad7392de01295188c760f71a6125fa28e5f6370da8d11b0756de801e2484af6d7c6a4590731ce
+DIST python-ctags3-1.2.3.tar.gz 45646 SHA256 57a0ef06bc4678267aa991086d7643ecb268986ab94a2b643d328f7bbb9a1ad8 SHA512 3bbe730e75a5ae36208113c6e2c43894942002ee37ed700990416fe54d5644b2d2be795935d1392191aae11797ec613ca143343a287596a0a327027c2f170525 WHIRLPOOL 1e4aa102b84f1e8bcbf1a3da89b709fc63497a7840e8c8ca99077c4dcc4a53e36e26248021a93b31a3a270c1935bf0ac672d8cc498db45ed82a577b0a8e8d9eb
diff --git a/dev-python/python-ctags/python-ctags-1.2.3.ebuild b/dev-python/python-ctags/python-ctags-1.2.3.ebuild
new file mode 100644
index 000000000000..f7117dd62186
--- /dev/null
+++ b/dev-python/python-ctags/python-ctags-1.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/jonashaag/python-ctags3"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ esetup.py test
+}