summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-daap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-daap')
-rw-r--r--dev-python/python-daap/Manifest1
-rw-r--r--dev-python/python-daap/metadata.xml6
-rw-r--r--dev-python/python-daap/python-daap-0.7.1-r1.ebuild31
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-daap/Manifest b/dev-python/python-daap/Manifest
new file mode 100644
index 000000000000..daae0524a53d
--- /dev/null
+++ b/dev-python/python-daap/Manifest
@@ -0,0 +1 @@
+DIST PythonDaap-0.7.1.tar.gz 25944 SHA256 ea1d3a8141654781a0df31e6607c4722436fa33eb2e9934492770b3b61be8122 SHA512 9ed6f1964fa0b357ee2d1e81dbdf79303f12feb1e753e6e8c987f28212a2eb3041fe1f443a4e5e43c196808192f116d045b0ea6d42dc76020ff4f252d423eca8 WHIRLPOOL 1099606784e69534d9ab115d6a561ebc6f9bff940c17d3cb1bf907c8484cc74f52f2a9c8aafd06e92cdc742bdf04e0172ca5f18d275666d3ba808ba5e0dfe3f8
diff --git a/dev-python/python-daap/metadata.xml b/dev-python/python-daap/metadata.xml
new file mode 100644
index 000000000000..414a5eeccf59
--- /dev/null
+++ b/dev-python/python-daap/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/python-daap/python-daap-0.7.1-r1.ebuild b/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..3fc3cbb84be2
--- /dev/null
+++ b/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="PythonDaap-${PV}"
+
+DESCRIPTION="PyDaap is a DAAP client implemented in Python, based on PyTunes"
+HOMEPAGE="http://jerakeen.org/code/pythondaap"
+SRC_URI="http://jerakeen.org/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}