summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-18 11:59:17 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-18 12:00:04 +0100
commitb8e8108ae07f7cd0a96bba0f8f4d275f61bf276d (patch)
tree81bde7136d16e1ab9fc6de9c75c525be6741c719 /dev-python/python-ddp/python-ddp-0.1.5.ebuild
parentdev-python/meteor-ejson: initial import; ebuild by me (diff)
downloadgentoo-b8e8108ae07f7cd0a96bba0f8f4d275f61bf276d.tar.gz
gentoo-b8e8108ae07f7cd0a96bba0f8f4d275f61bf276d.tar.bz2
gentoo-b8e8108ae07f7cd0a96bba0f8f4d275f61bf276d.zip
dev-python/python-ddp: initial import; ebuild by me
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/python-ddp/python-ddp-0.1.5.ebuild')
-rw-r--r--dev-python/python-ddp/python-ddp-0.1.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-ddp/python-ddp-0.1.5.ebuild b/dev-python/python-ddp/python-ddp-0.1.5.ebuild
new file mode 100644
index 000000000000..8a9c1faed5b1
--- /dev/null
+++ b/dev-python/python-ddp/python-ddp-0.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="An event driven ddp client"
+HOMEPAGE="https://pypi.python.org/pypi/python-ddp https://github.com/hharnisc/python-ddp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/pyee[${PYTHON_USEDEP}]
+ dev-python/ws4py[${PYTHON_USEDEP}]
+ dev-python/meteor-ejson[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"