summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:52:23 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:52:23 +0100
commit6020877cb31e079a18bdf886551e1778158deb13 (patch)
tree471ff52589b047191bf8f08f25005e0ebde376e2 /dev-python/python-debian/python-debian-0.1.28.ebuild
parentdev-python/python-barbicanclient: Remove old (diff)
downloadgentoo-6020877cb31e079a18bdf886551e1778158deb13.tar.gz
gentoo-6020877cb31e079a18bdf886551e1778158deb13.tar.bz2
gentoo-6020877cb31e079a18bdf886551e1778158deb13.zip
dev-python/python-debian: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/python-debian/python-debian-0.1.28.ebuild')
-rw-r--r--dev-python/python-debian/python-debian-0.1.28.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/python-debian/python-debian-0.1.28.ebuild b/dev-python/python-debian/python-debian-0.1.28.ebuild
deleted file mode 100644
index 4754c4177bd2..000000000000
--- a/dev-python/python-debian/python-debian-0.1.28.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_5 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python modules to work with Debian-related data formats"
-HOMEPAGE="https://packages.debian.org/sid/python-debian"
-SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( app-arch/dpkg )"
-
-RESTRICT="test"
-
-python_compile_all() {
- "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
-}
-
-python_test() {
- # Tests currently fail with >=app-crypt/gnupg-2.1
- # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782904
- pushd tests > /dev/null || die
- "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
- popd > /dev/null || die
-}