summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-debian
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/files/python-debian-0.1.26-CVE-2015-0840.patch29
-rw-r--r--dev-python/python-debian/files/python-debian-0.1.26-fix-tests.patch24
-rw-r--r--dev-python/python-debian/metadata.xml9
-rw-r--r--dev-python/python-debian/python-debian-0.1.26.ebuild45
-rw-r--r--dev-python/python-debian/python-debian-0.1.27.ebuild46
6 files changed, 155 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
new file mode 100644
index 000000000000..5f894bddda9b
--- /dev/null
+++ b/dev-python/python-debian/Manifest
@@ -0,0 +1,2 @@
+DIST python-debian_0.1.26.tar.xz 289496 SHA256 601e2a096c1490669f35080544875857bdc54b5f43bf1a37f88fccbf3740b4f8 SHA512 c857bdeaf651626c1b9d1f0f114bae961d073771f0a38caaa06785323bd586cf15fd2bf662a7bdc3af148f387756260b9d81378fdd5044bfabf7388de79c4d5a WHIRLPOOL 1dcf9a855e75ed483551edffba72265878208f3e55adf9e206bb79ac8462c1186251231f97368b1673ff73a3c38f6c5cf37195480fe010b2b7199e829317a4d3
+DIST python-debian_0.1.27.tar.xz 289692 SHA256 3a21d07553d46c0cf7961b13483e62005d8793a3780e79d1191b357f50174eab SHA512 101f49ce2337266856f6cf8f6d33c42d9fa2a281194a7d6fb2328d6e5f46574a7b742b04c4250e2384c197c6e6886c0e9f7b504e8c2230afaa00777e1a0057ab WHIRLPOOL f8b867fbbd236d685acbdf880bf636efb59f033788365aeea52e898217735bd0117526c2f67cfe9205d3f31b5d8da68eb5e6e6ec1ad2920a2ed0d4d54616c38f
diff --git a/dev-python/python-debian/files/python-debian-0.1.26-CVE-2015-0840.patch b/dev-python/python-debian/files/python-debian-0.1.26-CVE-2015-0840.patch
new file mode 100644
index 000000000000..d4cde15e6d2c
--- /dev/null
+++ b/dev-python/python-debian/files/python-debian-0.1.26-CVE-2015-0840.patch
@@ -0,0 +1,29 @@
+From 94a5864b6666ca5c2d0760702f386047189a248e Mon Sep 17 00:00:00 2001
+From: Guillem Jover <guillem@debian.org>
+Date: Thu, 9 Apr 2015 23:16:48 +0200
+Subject: [PATCH] deb822: Fix OpenPGP Armor Header Line parsing
+
+We should only accept [\r\t ] as trailing whitespace, although RFC4880
+does not clarify what whitespace really maps to, we should really match
+the GnuPG implementation anyway, as that is what we use to verify the
+signatures.
+---
+ lib/debian/deb822.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/debian/deb822.py b/lib/debian/deb822.py
+index 0c0748e..c1dcb17 100644
+--- a/lib/debian/deb822.py
++++ b/lib/debian/deb822.py
+@@ -638,7 +638,7 @@ class Deb822(Deb822Dict):
+ lines = []
+ gpg_post_lines = []
+ state = b'SAFE'
+- gpgre = re.compile(br'^-----(?P<action>BEGIN|END) PGP (?P<what>[^-]+)-----\s*$')
++ gpgre = re.compile(br'^-----(?P<action>BEGIN|END) PGP (?P<what>[^-]+)-----[\r\t ]*$')
+ # Include whitespace-only lines in blank lines to split paragraphs.
+ # (see #715558)
+ blank_line = re.compile(b'^\s*$')
+--
+2.2.1.209.g41e5f3a
+
diff --git a/dev-python/python-debian/files/python-debian-0.1.26-fix-tests.patch b/dev-python/python-debian/files/python-debian-0.1.26-fix-tests.patch
new file mode 100644
index 000000000000..189f83ac28e5
--- /dev/null
+++ b/dev-python/python-debian/files/python-debian-0.1.26-fix-tests.patch
@@ -0,0 +1,24 @@
+ tests/test_deb822.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/test_deb822.py b/tests/test_deb822.py
+index 698366b..c989d3f 100755
+--- a/tests/test_deb822.py
++++ b/tests/test_deb822.py
+@@ -468,6 +468,7 @@ class TestDeb822(unittest.TestCase):
+ for d in deb822.Deb822.iter_paragraphs(text)])
+ self.assertEqual(2, count)
+
++ @unittest.skip("Seems to be broken")
+ def test_iter_paragraphs_with_extra_whitespace(self):
+ """ Paragraphs not elided when stray whitespace is between
+
+@@ -920,7 +921,7 @@ Description: python modules to work with Debian-related data formats
+ with open_utf8(filename) as fh:
+ paragraphs = list(deb822.Deb822.iter_paragraphs(
+ fh, use_apt_pkg=True))
+- self.assertEqual(paragraphs[0]['Build-Depends'], 'debhelper,')
++ self.assertEqual(paragraphs[0]['Build-Depends'], 'debhelper,\n python')
+ finally:
+ os.remove(filename)
+
diff --git a/dev-python/python-debian/metadata.xml b/dev-python/python-debian/metadata.xml
new file mode 100644
index 000000000000..bdd3b1dee57e
--- /dev/null
+++ b/dev-python/python-debian/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-debian/python-debian-0.1.26.ebuild b/dev-python/python-debian/python-debian-0.1.26.ebuild
new file mode 100644
index 000000000000..31dd887e149c
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.26.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="http://packages.debian.org/sid/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-CVE-2015-0840.patch
+ "${FILESDIR}"/${P}-fix-tests.patch
+ )
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ pushd tests > /dev/null || die
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/ )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/python-debian/python-debian-0.1.27.ebuild b/dev-python/python-debian/python-debian-0.1.27.ebuild
new file mode 100644
index 000000000000..b841b0aba42d
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.27.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="http://packages.debian.org/sid/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.26-fix-tests.patch
+ )
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ # Tests currently fail with >=app-crypt/gnupg-2.1
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782904
+ pushd tests > /dev/null || die
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/ )
+ distutils-r1_python_install_all
+}