summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-05 19:23:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-05 20:30:52 +0100
commit51d7eab75157d343b5d7e4740e5f0ada4c2d567c (patch)
tree7a0a307c7d2e19a885040755b5aa2c4910fe834f /dev-python/python-docs/python-docs-3.7.6.ebuild
parentdev-python/python-docs: Bump to 3.6.10 (diff)
downloadgentoo-51d7eab75157d343b5d7e4740e5f0ada4c2d567c.tar.gz
gentoo-51d7eab75157d343b5d7e4740e5f0ada4c2d567c.tar.bz2
gentoo-51d7eab75157d343b5d7e4740e5f0ada4c2d567c.zip
dev-python/python-docs: Bump to 3.7.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs/python-docs-3.7.6.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.7.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.7.6.ebuild b/dev-python/python-docs/python-docs-3.7.6.ebuild
new file mode 100644
index 000000000000..5f4f82981932
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.7.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}