summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-02 12:42:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-02 12:42:54 +0100
commit2d2c107d5f6864a57193a4c7394450991c233778 (patch)
treef6f897c50428e3cb1223e6d289f3c03e3ad1e3ff /dev-python/python-docs
parentdev-python/python-docs: Bump to 3.9.16 (diff)
downloadgentoo-2d2c107d5f6864a57193a4c7394450991c233778.tar.gz
gentoo-2d2c107d5f6864a57193a4c7394450991c233778.tar.bz2
gentoo-2d2c107d5f6864a57193a4c7394450991c233778.zip
dev-python/python-docs: Bump to 3.8.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.8.16.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index fe04a4ab3f14..2e23e402e1d3 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -4,5 +4,6 @@ DIST python-3.10.9-docs-html.tar.bz2 7379489 BLAKE2B ab7bc918417682179d60d80685d
DIST python-3.11.0-docs-html.tar.bz2 7663300 BLAKE2B 5a0ba8d6691c96f5878f4f03238aaed09e9cf884a2f0aab65a70d5adec160318e3ff1ed89644ff9a6918d543ea310d88d7304dbca51ccb033d83f05c875a47c1 SHA512 0077e43f792925b8a01411243acd7862e1292e8740b4ae7ed734bd6f5d574120886e9ba37da28c057182a4504e5b4f53022818b80ecaefd2c4dfa7d8e5e446dd
DIST python-3.11.1-docs-html.tar.bz2 7701638 BLAKE2B 9c5452c2b8601dc5f9b681ebe8e5bbf6a74f915310554c158997bed0fdf471354c6de0eb260b31717cb9310f0d96b3a5ff497173cd17e2b278372e6af12f9ad5 SHA512 2541b13c2b7b06aa4d8750a4399f761619600d8978e691f0910365329167565d8a306d45895e3fb6c83e6b32b8e84943b0056fcd6264539500bac7a5625856ba
DIST python-3.8.15-docs-html.tar.bz2 6695025 BLAKE2B 614bd68c7038887e4d8f1758b7396e11683121fa22b8b3335dc9425fb6991e398ee64cf07ed4ca0d7273dc4943e7c9fcefe36cf4dcb51dcaa439219011bbe4e1 SHA512 c05cdf16c59ef213872b08bd54d0ddcef5f11bd80cfa78be21c9e57828bd0c7a63b553f525b6e68c578d6098c427e84f5f609680a74421c6a9baa58186b46c34
+DIST python-3.8.16-docs-html.tar.bz2 6697934 BLAKE2B 99fb1b8e95c3719b1146e845051fa6b9fbf61fabfdd1fe6d93a44e6a46f4b4e44c9ce0adef89cfdeafc8b67d290adda21d295f492a8f54c069ad86fba4952c0b SHA512 aaffc1f4d56be0ff7fbd35c7ca690d9089f9686d957669852aff1406efad2bee52b2b965ffd652780da6048ff9d89e6bbc421e92588841b89d73af43ad4970fb
DIST python-3.9.15-docs-html.tar.bz2 6964615 BLAKE2B c5faf1c6d86dba0ceae0a613a0c0bfd86b9605a134762872bc30dd6df113cc836d551032cfb4ba5812aa0d47933bcff28eeff0b68331e4dff1d27497d6e20ff9 SHA512 7f94c2c9569f3e9aa87ab90edbe584b6871a686fee72d8e257a7ae63af301596f7aae1bd63fcac30fa67bdf396453ec6cadc85d3b668514514927131cf70b5d0
DIST python-3.9.16-docs-html.tar.bz2 6965048 BLAKE2B 14d30cf5c444b993409751d17959bc46668d2b6e5be76e10d36adb0b8704a2a3908d829e8aa12d384efab31f8b60b462f711f2fa6adf8bc84fbdfe25e4cbc703 SHA512 38828ca880e3ed84a705dba465430f1b9623fec830662805008847c5d44ce04225ea7c2173d3eb138fd98e134fa2bb9ed84788e2b1d045bf9cf20e78e12d4472
diff --git a/dev-python/python-docs/python-docs-3.8.16.ebuild b/dev-python/python-docs/python-docs-3.8.16.ebuild
new file mode 100644
index 000000000000..e0ae576a6a47
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.8.16.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}