summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-05 11:41:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-05 11:48:47 +0100
commit49c2c592e94c2ac0ec341e88623d4a853cf2e8e9 (patch)
tree1a39f245d68a07d7bead8389a32ea96fc9b67fe1 /dev-python/python-docs
parentapp-crypt/johntheripper-jumbo: fixed installation of docs in live (diff)
downloadgentoo-49c2c592e94c2ac0ec341e88623d4a853cf2e8e9.tar.gz
gentoo-49c2c592e94c2ac0ec341e88623d4a853cf2e8e9.tar.bz2
gentoo-49c2c592e94c2ac0ec341e88623d4a853cf2e8e9.zip
dev-python/python-docs: Bump to 3.8.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.8.7.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index 5ba8afa11981..5d481d6810e2 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -2,4 +2,5 @@ DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709
DIST python-3.6.12-docs-html.tar.bz2 6013089 BLAKE2B dc1c9f702bdd8be619c3cd6fd0f8cab022b8d7542ace7a7b7f63b9642f693c63b036f03248cf7ea0108ab7e33655379ca906c8ef7c35d8242517ead721a83778 SHA512 da28da84f5e8f889f328fafb4d17beb6cfc52c5703bcf5080cfbaea552f414d6f0a682aaacb2f04fa32e9453a1bdaae8ff108c38a4486170bd0edf1efacafdf7
DIST python-3.7.9-docs-html.tar.bz2 6285801 BLAKE2B bc76a90bed3f9126a63fc76bc7ec858b90dcf827eb0af19652ee987aa3feeef9de71be0e14b33f98ee5733b9eeecd3d6ec01837fcbab31d505e389ea99d6fd0a SHA512 243327bdcb85b696fccf20b3cb841b398a672f07e34f441323418651ead58ab3346eff39e78501130b5d97e5d87fb72c945a9c4b9082b26577f33bd095791d55
DIST python-3.8.6-docs-html.tar.bz2 6578280 BLAKE2B efdc62b2d570cbe7e69be1cf118250ee89f1b09af7e7db306970e764dcc9e6f20bda9230fe934ecc0891a1d79370294bc42170713b9471d05f23a468f09015fc SHA512 be0d61a9556fbdd24ab124cfdf220b3bdb537cc02d5896f8f4c75cb73e3cfd5c2947c060d049b57bf5576b4b2d1c7f0f3987070d70ce883dea023e1feab1a630
+DIST python-3.8.7-docs-html.tar.bz2 6583700 BLAKE2B 7509e4bb530f272653f0efcc6582628f80e60ddf143085cc8fb9492a686d8de2be599be3e0a38ae0271526704c04e7bbe0bc064dbbf6712d03b8f4166f6e8cda SHA512 317217948168d870dee57f2b1633c5d3dbd1a54963f5595dda4cccdf902ea48bbc70369f98e2c03958047a76966aabf9842b87adade21bb1fc5ec01c3db694f1
DIST python-3.9.0-docs-html.tar.bz2 6771373 BLAKE2B 301b8687043277a3d11dc497985769efdeaf33f8af2fc3d52b8a0b50322851402c1a1b273e782db6bd7ac51bbd94f7345c0995d0dd4f4d37bce10351620c6f6e SHA512 d04957f4895ab8f6bef8467d8b5282e0b3e5c453e2168c25123ee7aefd7a3d6d8b918e9f455bbf82913370a00181b8c00998ec2ae67c763aeda237c5b3a42097
diff --git a/dev-python/python-docs/python-docs-3.8.7.ebuild b/dev-python/python-docs/python-docs-3.8.7.ebuild
new file mode 100644
index 000000000000..bfc00bc95def
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.8.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}