summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 20:17:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 20:19:10 +0200
commit577d04535cd56925b28ebec89745c576f2cccdf4 (patch)
tree2148c60eb126e9cf3d0e8838ddfe018e445f31e5 /dev-python/python-docs
parentdev-python/python-docs: Bump to 3.6.12 (diff)
downloadgentoo-577d04535cd56925b28ebec89745c576f2cccdf4.tar.gz
gentoo-577d04535cd56925b28ebec89745c576f2cccdf4.tar.bz2
gentoo-577d04535cd56925b28ebec89745c576f2cccdf4.zip
dev-python/python-docs: Bump to 3.7.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.7.9.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index 3310f1502d0e..003eca63513f 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -5,5 +5,6 @@ DIST python-3.6.11-docs-html.tar.bz2 6012332 BLAKE2B 9daa262be400912c82382dd8e87
DIST python-3.6.12-docs-html.tar.bz2 6013089 BLAKE2B dc1c9f702bdd8be619c3cd6fd0f8cab022b8d7542ace7a7b7f63b9642f693c63b036f03248cf7ea0108ab7e33655379ca906c8ef7c35d8242517ead721a83778 SHA512 da28da84f5e8f889f328fafb4d17beb6cfc52c5703bcf5080cfbaea552f414d6f0a682aaacb2f04fa32e9453a1bdaae8ff108c38a4486170bd0edf1efacafdf7
DIST python-3.7.7-docs-html.tar.bz2 6259882 BLAKE2B 5ff9dbbf0941385453283a47df2bc7ee085c3c8dd0c2fc0f2b98af766ec31b1f1d1c04586a26f978287ff575641c1710b373a0093fe1b928cd73362e7e30630c SHA512 5a556a0c8dd739c16d7b6105e11ef62adaa939bd784d4f5fa0df26555c7d1908c09626c091dc0bf2d892624274646573c9fde5a5b218adf770bcf7c097976a06
DIST python-3.7.8-docs-html.tar.bz2 6283763 BLAKE2B 617feba1f9a751fe98f124e572339cbad96abccc0c0c00339331edf52596f47dc73c13b8fcfae4343ea5515ecbf59c697b0611358ff3788e380695b2bb9e5a20 SHA512 8aaf57b0a539d98a7158ffeed03b4c631ca45e34bfc9000547b4372ecd397e79a652f297674d3af631c696d80272aedec3930f4a01b584e17c3e41e9f933e16c
+DIST python-3.7.9-docs-html.tar.bz2 6285801 BLAKE2B bc76a90bed3f9126a63fc76bc7ec858b90dcf827eb0af19652ee987aa3feeef9de71be0e14b33f98ee5733b9eeecd3d6ec01837fcbab31d505e389ea99d6fd0a SHA512 243327bdcb85b696fccf20b3cb841b398a672f07e34f441323418651ead58ab3346eff39e78501130b5d97e5d87fb72c945a9c4b9082b26577f33bd095791d55
DIST python-3.8.2-docs-html.tar.bz2 6536475 BLAKE2B f807caa25596aebd8fb441366f7986db0525b9262da906700f167b997795035daa1fe80b8b5ffdfb6c4fa9b552fd55c8546af110e3686a19c855966c58170b4a SHA512 1453770abba67b147a9a8911de3f31972beeea3b7249b1009944635e30e8b4143f1ceaee447dc9f14d85bd09bc67671b922e3e931b8e1279b46ab10ab5c91091
DIST python-3.8.3-docs-html.tar.bz2 6556303 BLAKE2B aa5d29680dc274af33346b2651ae0d0a820eaa38b2571d210991a35f0db35b2fd155ff57cfbf9ab1cdace129ac6c3acb0abf40787c79987788c14fe4f8891a98 SHA512 5aad0ec599ac4ee478baac91c0ac38d7ac44bb8979bac9263aaafb515103420e0bb8ca4a20b8b915661d1804fc0ad02aa9cfbf00d60a5184df27b0a082109614
diff --git a/dev-python/python-docs/python-docs-3.7.9.ebuild b/dev-python/python-docs/python-docs-3.7.9.ebuild
new file mode 100644
index 000000000000..16f1d2327d67
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.7.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}