summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:19:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:22:03 +0100
commit7244794d283080a87b4e6db2a919cd46c1e9a4b0 (patch)
tree996683425709b1f4172b926a7738bd8658620837 /dev-python/python-docs
parentdev-python/python-docs: Stabilize in sync with dev-lang/python (diff)
downloadgentoo-7244794d283080a87b4e6db2a919cd46c1e9a4b0.tar.gz
gentoo-7244794d283080a87b4e6db2a919cd46c1e9a4b0.tar.bz2
gentoo-7244794d283080a87b4e6db2a919cd46c1e9a4b0.zip
dev-python/python-docs: Bump to 3.6.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.6.13.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index fd28ddac1231..31110bc4f2c7 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -1,5 +1,6 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.6.12-docs-html.tar.bz2 6013089 BLAKE2B dc1c9f702bdd8be619c3cd6fd0f8cab022b8d7542ace7a7b7f63b9642f693c63b036f03248cf7ea0108ab7e33655379ca906c8ef7c35d8242517ead721a83778 SHA512 da28da84f5e8f889f328fafb4d17beb6cfc52c5703bcf5080cfbaea552f414d6f0a682aaacb2f04fa32e9453a1bdaae8ff108c38a4486170bd0edf1efacafdf7
+DIST python-3.6.13-docs-html.tar.bz2 6016532 BLAKE2B b1aa4fea09f84615146a160ebfc7f2a40481397f25549f8935ea83b5dd5d6db83c0e8ecec94efa9941712186f93b8564fbda7a579550919bfe3ce47adc6c0a84 SHA512 7bdc77767211a652dbbe654cf9675e325a959d1d90eb751fa2f86abd04ddc41301d1035c8cf1a4968a8f23c97f95cf87b06763fd97f7844ac13c365b39dfcd8b
DIST python-3.7.9-docs-html.tar.bz2 6285801 BLAKE2B bc76a90bed3f9126a63fc76bc7ec858b90dcf827eb0af19652ee987aa3feeef9de71be0e14b33f98ee5733b9eeecd3d6ec01837fcbab31d505e389ea99d6fd0a SHA512 243327bdcb85b696fccf20b3cb841b398a672f07e34f441323418651ead58ab3346eff39e78501130b5d97e5d87fb72c945a9c4b9082b26577f33bd095791d55
DIST python-3.8.6-docs-html.tar.bz2 6578280 BLAKE2B efdc62b2d570cbe7e69be1cf118250ee89f1b09af7e7db306970e764dcc9e6f20bda9230fe934ecc0891a1d79370294bc42170713b9471d05f23a468f09015fc SHA512 be0d61a9556fbdd24ab124cfdf220b3bdb537cc02d5896f8f4c75cb73e3cfd5c2947c060d049b57bf5576b4b2d1c7f0f3987070d70ce883dea023e1feab1a630
DIST python-3.8.7-docs-html.tar.bz2 6583700 BLAKE2B 7509e4bb530f272653f0efcc6582628f80e60ddf143085cc8fb9492a686d8de2be599be3e0a38ae0271526704c04e7bbe0bc064dbbf6712d03b8f4166f6e8cda SHA512 317217948168d870dee57f2b1633c5d3dbd1a54963f5595dda4cccdf902ea48bbc70369f98e2c03958047a76966aabf9842b87adade21bb1fc5ec01c3db694f1
diff --git a/dev-python/python-docs/python-docs-3.6.13.ebuild b/dev-python/python-docs/python-docs-3.6.13.ebuild
new file mode 100644
index 000000000000..bfc00bc95def
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.6.13.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}