summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 00:41:36 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 00:58:57 +0100
commit79f552c75f7d75deeab8b7636e013a0357456559 (patch)
tree18caac2ca10df8f7e35398d4b09646494e6a4b38 /dev-python/python-docs
parentdev-python/python-docs: Bump to 2.7.14 (diff)
downloadgentoo-79f552c75f7d75deeab8b7636e013a0357456559.tar.gz
gentoo-79f552c75f7d75deeab8b7636e013a0357456559.tar.bz2
gentoo-79f552c75f7d75deeab8b7636e013a0357456559.zip
dev-python/python-docs: Bump to 3.4.6
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.4.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index 8f2c60a81cde..9574faea39bc 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -3,5 +3,6 @@ DIST python-2.7.12-docs-html.tar.bz2 4601696 BLAKE2B c6e1c1f65365ffd64d8779d1521
DIST python-2.7.14-docs-html.tar.bz2 4604956 BLAKE2B 743f3cf0c741916d2efbf8ebdee077800dad7d9e38fc7a2f60e2fb8f0e3dd3978fda8b286fccd6cbba87ed3e6fd289401019131c00a03809a1528533cd29488d SHA512 3a8c0e8d083880e5e174090eb39514b27b0f00021b3874a2ffcfcaf4d43020764d9d8415d2387e0ce8e59e6e193571cbad06dbfdd1d30f8be06e1f27b375bc10
DIST python-3.3.5-docs-html.tar.bz2 4955315 BLAKE2B 4469c9762503bc08f61e4d8d82f86f7eea2663cf1a211b730f8cf8c1938c4eb880929a33daaed61082835f8dc584468447333ad0e33c81252ab362d2519c7d42 SHA512 6cf6d02bf980609561ec829407e0a4d541ddf949db0b6d3156f9fa90ed7c87f9ef16128e9c8226887568489826efcdde5ea38af246ec235a077227d73736ea71
DIST python-3.4.3-docs-html.tar.bz2 5444773 BLAKE2B cb3e6d089dd7ce1aa87de341cf0849c3d9dcbac2d9f2052c0578f8090d87470460272a9e3ded9ea28534605bf77a9eae6a8da333856eee95e1ba09c8db1708a4 SHA512 492038df0afb05d60806d56d66e06069d195249db708e4261d39fa6206e0baec5c2db730431b5be03d8d37296d935f39a25bf1d449fb29521bdc4823584b9bf9
+DIST python-3.4.6-docs-html.tar.bz2 5517260 BLAKE2B c8e605a3b27358c22e2047241a4b92b3918a6fff0ef3b8cc8153ca6fd8d17eb38e58f83f47e27a0b19ef73f3a8339f28dfcce7df621c1deeadc6fb746522d2e9 SHA512 a561ca54fe3fd8b9f1a419eb95ffd6001eaa303bf0b5ba75f726915d94926d3ddde0b918cd7ac8897e202b61226832d332aeb748ea1cda22db09132ce64c7c0d
DIST python-3.5.2-docs-html.tar.bz2 5747460 BLAKE2B 89de5d1d5b54d3d33af8ea756106595fc8f4722bf326b6302766b8dddf5b447bd031d950ebfd471c2ab62fc4e61e267ff1f7d27d4a6d412841bfccd5474146df SHA512 2a9ce5b304c6edf3165728a1fe0c189222f8b105c446ca9026ce453d013c9498b4c53085fdef776b977d058fc138ba3af5ea9bf26291469ce47239ee1a8d9286
DIST python-3.6.0-docs-html.tar.bz2 5880912 BLAKE2B 599f56a3ce059110832b1a7756d874f922b0ec2e30a3e757ed8d0d9413d4f54fe295bae57aa17aa4ac30db5d767090a5cb170c6c03ab8d393deec9715a6cff69 SHA512 433221763e410b1fea9a592b25fa9695af369bfc3d49055d4f912fbe34a54ebdf69a0ad2579d4f886d08d08b107c83264186851bb962c7ef2c1fc863e984f529
diff --git a/dev-python/python-docs/python-docs-3.4.6.ebuild b/dev-python/python-docs/python-docs-3.4.6.ebuild
new file mode 100644
index 000000000000..c82d0d92315b
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.4.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}" || die
+ doenvd "60python-docs-${SLOT}"
+}