summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-24 19:48:45 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-24 19:58:18 +0100
commite3b2c5e47a1a1b9173ce3e2d276c2850858f2bad (patch)
treec0e4cc0778e2b3ed600571bc56e32cd747b11be6 /dev-python/python-docs
parentsci-mathematics/planarity: maintainer stabilize on amd64/x86. (diff)
downloadgentoo-e3b2c5e47a1a1b9173ce3e2d276c2850858f2bad.tar.gz
gentoo-e3b2c5e47a1a1b9173ce3e2d276c2850858f2bad.tar.bz2
gentoo-e3b2c5e47a1a1b9173ce3e2d276c2850858f2bad.zip
dev-python/python-docs: Bump to 3.7.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.7.7.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index 5b219c8ce5fd..0383152e5cc0 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -5,4 +5,5 @@ DIST python-3.6.3-docs-html.tar.bz2 5945784 BLAKE2B 88473f63c6a0d533d568184b8459
DIST python-3.6.4-docs-html.tar.bz2 5955729 BLAKE2B 71e6e198069297860ac84be125586cb5757a34e2b342358517d62656734545fc221812f3c54cdbdb877188648551c3e1cc9331f159d011ca2b0bef587847a471 SHA512 a4cf51ec0e7127f417b066e2727258395954dfc5f1aaa0ad1d25e81dae40ace0d51b18413600fce0f5b1002e4b130a3914b7c9244025375e8fe5332c8d86635d
DIST python-3.7.0-docs-html.tar.bz2 6222504 BLAKE2B 150382e6ce9c241bf8654efc2c7515e1399291eca38b91c44c51d24302fc239a764af7d22dcc69378338cb3c0f7e2d7e517af238f8c38f32be8a76037880206c SHA512 f5583e8d2792932ff3c90575ce98446f0f11eab3a78a1ea8df0203f29583ff9c2831879817ae5fb23cfdb32238d385361b7956c352c6431e9801e6509d3c5f09
DIST python-3.7.6-docs-html.tar.bz2 6248802 BLAKE2B b2baff27bf3fc61ebe521b5bf621c265a50336d63ec8c2e14f8f2fa75b552fa4f959b3448ed39ebf18bece46cdc14f8a7a62cae3fcdd4f44e3db09489807bf4f SHA512 52657627dfe088184afbc0827731cf919884f21ae483c934a84e1e93bd1b03fe7b948da8ea8dfc1ba80e0557504d14eab729d22b7230000ba34731e1b866a253
+DIST python-3.7.7-docs-html.tar.bz2 6259882 BLAKE2B 5ff9dbbf0941385453283a47df2bc7ee085c3c8dd0c2fc0f2b98af766ec31b1f1d1c04586a26f978287ff575641c1710b373a0093fe1b928cd73362e7e30630c SHA512 5a556a0c8dd739c16d7b6105e11ef62adaa939bd784d4f5fa0df26555c7d1908c09626c091dc0bf2d892624274646573c9fde5a5b218adf770bcf7c097976a06
DIST python-3.8.1-docs-html.tar.bz2 6527362 BLAKE2B b13fb15b93f7a244e082b7cc8ceac6fffac5b81bffa5c183c546e19dcf8839ad227d3263cc5662717e46f1daccca7dc1299260c1cadf601ac43dd61d501e256f SHA512 5cfcdce2fc12824d512e59689b070541f461404ff74aa5ab980576af95449c18c9340687a405af6ea48f7f1826f85a26cd86dfbe07acdb984687bc0fdb5a8edd
diff --git a/dev-python/python-docs/python-docs-3.7.7.ebuild b/dev-python/python-docs/python-docs-3.7.7.ebuild
new file mode 100644
index 000000000000..5f4f82981932
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.7.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}