summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-28 13:53:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-28 13:56:47 +0200
commite42f11cba44096397cc545dbdaa198cddf16fd91 (patch)
tree233d963b4e2a40720a498029934b7135ae226a5a /dev-python/python-docs
parentdev-lang/python: Remove old (diff)
downloadgentoo-e42f11cba44096397cc545dbdaa198cddf16fd91.tar.gz
gentoo-e42f11cba44096397cc545dbdaa198cddf16fd91.tar.bz2
gentoo-e42f11cba44096397cc545dbdaa198cddf16fd91.zip
dev-python/python-docs: Bump to 3.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/Manifest1
-rw-r--r--dev-python/python-docs/python-docs-3.8.8.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-docs/Manifest b/dev-python/python-docs/Manifest
index e3829865441f..8d106946abe5 100644
--- a/dev-python/python-docs/Manifest
+++ b/dev-python/python-docs/Manifest
@@ -4,4 +4,5 @@ DIST python-3.6.13-docs-html.tar.bz2 6016532 BLAKE2B b1aa4fea09f84615146a160ebfc
DIST python-3.7.10-docs-html.tar.bz2 6289108 BLAKE2B ff751e3b847602f766389a4dc249bbb55776d91c7263a7b51b4699b3c65ab02a055e67c483d28a284c18b686086c21b2689a1b62373209a64dc102418d6fe26c SHA512 c303561ce3b758df1ee017ab8dad862adad116eedf1f2d0ed1180529e0af06526c9293810fe086f8223ec97b2c935cb08ca7e74bc20b9be93dc4e97909f5f561
DIST python-3.7.9-docs-html.tar.bz2 6285801 BLAKE2B bc76a90bed3f9126a63fc76bc7ec858b90dcf827eb0af19652ee987aa3feeef9de71be0e14b33f98ee5733b9eeecd3d6ec01837fcbab31d505e389ea99d6fd0a SHA512 243327bdcb85b696fccf20b3cb841b398a672f07e34f441323418651ead58ab3346eff39e78501130b5d97e5d87fb72c945a9c4b9082b26577f33bd095791d55
DIST python-3.8.7-docs-html.tar.bz2 6583700 BLAKE2B 7509e4bb530f272653f0efcc6582628f80e60ddf143085cc8fb9492a686d8de2be599be3e0a38ae0271526704c04e7bbe0bc064dbbf6712d03b8f4166f6e8cda SHA512 317217948168d870dee57f2b1633c5d3dbd1a54963f5595dda4cccdf902ea48bbc70369f98e2c03958047a76966aabf9842b87adade21bb1fc5ec01c3db694f1
+DIST python-3.8.8-docs-html.tar.bz2 6590826 BLAKE2B 3d63ed87030ce2a036ada92397bbb7ad5389105702deab5282148ee9ff5d4e93a1d2767e1e9487cff7fecd86fd46e2d7a216bf1578847f7b25f133d6d26ba038 SHA512 1f3da0cb48dd817a31b824ca88b27d8df6bf32d5e6348e339e4b4a06403d5aca37a0984d59d8d954ef037aa427ced77a8163c03887de51bd60ff25a6e5ef2682
DIST python-3.9.1-docs-html.tar.bz2 6806786 BLAKE2B 0101e59fd25bd57e8abbb9f289b2b48a7db8e4ad9a74e51e3c8977f85a0d5d731624fe61fdc376048166e1ffaadd69c8e97acc677024a9bb711ba958a5c43cef SHA512 aa87b27b895894281b923031af651d26627526f85e61fe09c88be081ff6471ae367364cea176b1e522e065c6ec98372504f769aa1d40382716004f90c3761d97
diff --git a/dev-python/python-docs/python-docs-3.8.8.ebuild b/dev-python/python-docs/python-docs-3.8.8.ebuild
new file mode 100644
index 000000000000..bfc00bc95def
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.8.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}