summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-dsv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-dsv')
-rw-r--r--dev-python/python-dsv/Manifest1
-rw-r--r--dev-python/python-dsv/files/python-dsv-1.4.1-wxversion.patch16
-rw-r--r--dev-python/python-dsv/metadata.xml13
-rw-r--r--dev-python/python-dsv/python-dsv-1.4.1-r1.ebuild29
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/python-dsv/Manifest b/dev-python/python-dsv/Manifest
new file mode 100644
index 000000000000..d0a3141e6845
--- /dev/null
+++ b/dev-python/python-dsv/Manifest
@@ -0,0 +1 @@
+DIST DSV-1.4.1.tar.gz 14682 SHA256 5d0ec99c45f8ea91ea920dcd2cdf2cdc9e721985551ea80718519ce70dc98f15 SHA512 c26df1efabff9e70b6dfd17f6ff928f022ad19cfa39af431ef7ac663687e8d80406b0ad471376e238eeb6fcbab31aa2a84eaeae2949173e22316eb92e51f7ada WHIRLPOOL 565ef07a5c87cc4090b8b75df0fb992561865563ac3a0a8adaac2d1bc893e664d0db4d66836d9f682b2e69f62b2fc1fb1c3cdb649d973672b87a731887ded97d
diff --git a/dev-python/python-dsv/files/python-dsv-1.4.1-wxversion.patch b/dev-python/python-dsv/files/python-dsv-1.4.1-wxversion.patch
new file mode 100644
index 000000000000..e72dd78ab28b
--- /dev/null
+++ b/dev-python/python-dsv/files/python-dsv-1.4.1-wxversion.patch
@@ -0,0 +1,16 @@
+--- DSV/DSV.py
++++ DSV/DSV.py
+@@ -134,6 +134,13 @@
+ os.putenv('LANG', 'C')
+
+ try:
++ import wxversion
++ wxversion.select("2.8")
++except Exception, e:
++ print >> sys.stderr, "%s: wxPython 2.8 not installed." %e
++ sys.exit(1)
++
++try:
+ from wxPython import wx, grid
+ except ImportError:
+ wx = None
diff --git a/dev-python/python-dsv/metadata.xml b/dev-python/python-dsv/metadata.xml
new file mode 100644
index 000000000000..43dfa177f5f6
--- /dev/null
+++ b/dev-python/python-dsv/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Python module for importing and exporting DSV (delimiter separated values) files.
+DSV is a generalization of CSV (comma separated values) and it is a common file
+format used by many programs to import and export data.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">python-dsv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-dsv/python-dsv-1.4.1-r1.ebuild b/dev-python/python-dsv/python-dsv-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..4501ca755f0a
--- /dev/null
+++ b/dev-python/python-dsv/python-dsv-1.4.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python module for importing and exporting DSV files"
+HOMEPAGE="http://python-dsv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/DSV-${PV}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/wxpython:2.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/DSV-${PV}
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/${P}-wxversion.patch
+
+ distutils-r1_python_prepare_all
+}