summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2016-12-27 18:39:37 -0500
committerPatrice Clement <monsieurp@gentoo.org>2017-01-02 10:59:35 +0100
commit43d5aa93a363d9ab39d190bd530c47d976ad20f2 (patch)
treebb2a5dd21497c4c18ad3b59d7a151c4493446043 /dev-python/python-editor/python-editor-1.0.3.ebuild
parentapp-admin/ulogd: remove old. (diff)
downloadgentoo-43d5aa93a363d9ab39d190bd530c47d976ad20f2.tar.gz
gentoo-43d5aa93a363d9ab39d190bd530c47d976ad20f2.tar.bz2
gentoo-43d5aa93a363d9ab39d190bd530c47d976ad20f2.zip
dev-python/python-editor: version bump to 1.0.3.
* EAPI=6 * KEYWORD="~arm" (tested on RK3288 armv7a) Package-Manager: Portage-2.3.0, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3265
Diffstat (limited to 'dev-python/python-editor/python-editor-1.0.3.ebuild')
-rw-r--r--dev-python/python-editor/python-editor-1.0.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/python-editor/python-editor-1.0.3.ebuild b/dev-python/python-editor/python-editor-1.0.3.ebuild
new file mode 100644
index 000000000000..841a33093d34
--- /dev/null
+++ b/dev-python/python-editor/python-editor-1.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Programmatically open an editor, capture the result."
+HOMEPAGE="https://github.com/fmoo/python-editor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"