summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 19:57:17 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 20:18:24 +0200
commit39703238d829b5ac6b80d3049f3614c25595823f (patch)
tree9cebcc8035575cce720c9d27e7101f570e23518f /dev-python/python-engineio/python-engineio-0.9.1.ebuild
parentdev-python/jingo: Bump (diff)
downloadgentoo-39703238d829b5ac6b80d3049f3614c25595823f.tar.gz
gentoo-39703238d829b5ac6b80d3049f3614c25595823f.tar.bz2
gentoo-39703238d829b5ac6b80d3049f3614c25595823f.zip
dev-python/python-engineio: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/python-engineio/python-engineio-0.9.1.ebuild')
-rw-r--r--dev-python/python-engineio/python-engineio-0.9.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-engineio/python-engineio-0.9.1.ebuild b/dev-python/python-engineio/python-engineio-0.9.1.ebuild
new file mode 100644
index 000000000000..57a324c6cbb5
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ esetup.py test || die
+}