summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-06 04:44:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-06 05:30:55 +0200
commitffdd99b0f4d1467a7aa943bbbc45f3aea8748445 (patch)
treeb3b3b459ef889d4fddf712405079a06f4b221494 /dev-python/python-engineio
parentdev-python/httpcore: Bump to 0.17.3 (diff)
downloadgentoo-ffdd99b0f4d1467a7aa943bbbc45f3aea8748445.tar.gz
gentoo-ffdd99b0f4d1467a7aa943bbbc45f3aea8748445.tar.bz2
gentoo-ffdd99b0f4d1467a7aa943bbbc45f3aea8748445.zip
dev-python/python-engineio: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.5.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 0b773e63d3b5..df84f1961137 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1,2 +1,3 @@
DIST python-engineio-4.4.0.gh.tar.gz 309353 BLAKE2B 4cf40802fddcce2e53e205bdbe73bdf0ec822e15581fe4a9939b8d05c3eb6ba82a99d089d4708169b197aa79e5b5f14001ff86f72025fc6d96c99ed6d73fe620 SHA512 b7995aaf2583ec58ac87f048608653ade3846dd103616ee90b3dc12cc7e27c7d37959cd3e1ebf6e138395ff6fad8cd011407b6660258715e513bf72c8a3e1f6f
DIST python-engineio-4.4.1.gh.tar.gz 309475 BLAKE2B 4ae5dd9887f4d3a70d4983d2a0f0de29b1a54d30961bfc430b8850ff4af73fa1cd9abad6caeb8248a44def42b02e26ecb0632dd9b4d57e2a7f44b33762659304 SHA512 a903ae4f5a4679f6d46fda09901b637ef8dcf2896ece8781460d27aab7c8da606e16a89ac5dea94c156d8196a7e931626b2310b41ddc61d4241b5e004ad2ca64
+DIST python-engineio-4.5.0.gh.tar.gz 309771 BLAKE2B ab58972ac543386c0254f6fe65041a88f6046312f7eac904128244b18a64107de174466b8934c9c6a51004c7614d199f1fd8362d816fdf8912cec29eddfc036b SHA512 3066fd2d3a3fc819318c4bd862c593e00012a29670ff76dbe926eae47c5ddd7a7483f16dedd9ef937d879f0533bff9eff4aee61ad4279651b39704722fac613b
diff --git a/dev-python/python-engineio/python-engineio-4.5.0.ebuild b/dev-python/python-engineio/python-engineio-4.5.0.ebuild
new file mode 100644
index 000000000000..705b082df961
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+BDEPEND="
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+EPYTEST_IGNORE=(
+ # eventlet is masked for removal
+ tests/common/test_async_eventlet.py
+)
+
+EPYTEST_DESELECT=(
+ # also eventlet
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+)