summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-06-17 23:46:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-06-18 00:05:09 +0200
commit1340aee7062458eed07f31178450522fd0ef63e9 (patch)
tree7eff3ff851d07a44a5e7ac4c6409a513b35a24fb /dev-python/python-gflags/files
parentdev-python/python-gflags: stable for amd64. mark stable for the remaining (diff)
downloadgentoo-1340aee7062458eed07f31178450522fd0ef63e9.tar.gz
gentoo-1340aee7062458eed07f31178450522fd0ef63e9.tar.bz2
gentoo-1340aee7062458eed07f31178450522fd0ef63e9.zip
dev-python/python-gflags: clean up old.
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-python/python-gflags/files')
-rw-r--r--dev-python/python-gflags/files/python-gflags-2.0-scripts-install.patch29
-rw-r--r--dev-python/python-gflags/files/python-gflags-2.0-skip-test-as-root.patch28
-rw-r--r--dev-python/python-gflags/files/python-gflags-2.0-tests-python-2.7.patch68
-rw-r--r--dev-python/python-gflags/files/python-gflags-2.0-tests-respect-tmpdir.patch58
4 files changed, 0 insertions, 183 deletions
diff --git a/dev-python/python-gflags/files/python-gflags-2.0-scripts-install.patch b/dev-python/python-gflags/files/python-gflags-2.0-scripts-install.patch
deleted file mode 100644
index e29ef951da57..000000000000
--- a/dev-python/python-gflags/files/python-gflags-2.0-scripts-install.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-The scripts are installed as 'data' rather than scripts.
-http://code.google.com/p/python-gflags/issues/detail?id=12
-
-From d544cdad63faa5a53ba524e39f091f4a18e1eeb8 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 16 Dec 2012 16:27:13 +0100
-Subject: [PATCH] Install Python scripts using 'scripts' key.
-
-This is necessary to ensure that the shebangs are properly replaced when
-installing for multiple Python implementations.
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 573db2d..ddad318 100755
---- a/setup.py
-+++ b/setup.py
-@@ -39,6 +39,6 @@ setup(name='python-gflags',
- author_email='google-gflags@googlegroups.com',
- url='http://code.google.com/p/python-gflags',
- py_modules=["gflags", "gflags_validators"],
-- data_files=[("bin", ["gflags2man.py"])],
-+ scripts=["gflags2man.py"],
- include_package_data=True,
- )
---
-1.8.0.2
-
diff --git a/dev-python/python-gflags/files/python-gflags-2.0-skip-test-as-root.patch b/dev-python/python-gflags/files/python-gflags-2.0-skip-test-as-root.patch
deleted file mode 100644
index 5eb2aa35b267..000000000000
--- a/dev-python/python-gflags/files/python-gflags-2.0-skip-test-as-root.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-http://bugs.gentoo.org/475134
-
-From 6e93aa28e1e116619a82e1b78ffbc15ce1133d51 Mon Sep 17 00:00:00 2001
-From: Michael Marineau <mike@marineau.org>
-Date: Thu, 27 Jun 2013 19:26:23 -0400
-Subject: [PATCH 3/3] Skip a permissions check when running as root.
-
----
- tests/gflags_unittest.py | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/tests/gflags_unittest.py b/tests/gflags_unittest.py
-index 091ebd9..ddd3b5c 100755
---- a/tests/gflags_unittest.py
-+++ b/tests/gflags_unittest.py
-@@ -1111,6 +1111,9 @@ class LoadFromFlagFileTest(googletest.TestCase):
-
- def testMethod_flagfiles_NoPermissions(self):
- """Test that --flagfile raises except on file that is unreadable."""
-+ # This test doesn't work as root
-+ if os.getuid() == 0:
-+ return
- tmp_files = self._SetupTestFiles()
- # specify our temp file on the fake cmd line
- fake_cmd_line = ('fooScript --SomeFlag some_arg --flagfile=%s'
---
-1.8.1.5
-
diff --git a/dev-python/python-gflags/files/python-gflags-2.0-tests-python-2.7.patch b/dev-python/python-gflags/files/python-gflags-2.0-tests-python-2.7.patch
deleted file mode 100644
index 2210b2b6eddd..000000000000
--- a/dev-python/python-gflags/files/python-gflags-2.0-tests-python-2.7.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-https://bugs.gentoo.org/447482
-
-------------------------------------------------------------------------
-r41 | jwilliams@endpoint.com | 2012-02-21 17:17:32 -0500 (Tue, 21 Feb 2012) | 5 lines
-
-Unit test updates for Python 2.7 compatibility
-
-* Add "msg" parameter to our versions of the test functions
-* Change regex to match the updated 2.7 float() ValueError response
-
-
-Index: tests/gflags_googletest.py
-===================================================================
---- tests/gflags_googletest.py (revision 40)
-+++ tests/gflags_googletest.py (revision 41)
-@@ -88,22 +88,22 @@ def MultiLineEqual(expected, actual):
-
-
- class TestCase(unittest.TestCase):
-- def assertListEqual(self, list1, list2):
-+ def assertListEqual(self, list1, list2, msg=None):
- """Asserts that, when sorted, list1 and list2 are identical."""
- # This exists in python 2.7, but not previous versions. Use the
- # built-in version if possible.
- if hasattr(unittest.TestCase, "assertListEqual"):
-- unittest.TestCase.assertListEqual(self, Sorted(list1), Sorted(list2))
-+ unittest.TestCase.assertListEqual(self, Sorted(list1), Sorted(list2), msg)
- else:
-- self.assertEqual(Sorted(list1), Sorted(list2))
-+ self.assertEqual(Sorted(list1), Sorted(list2), msg)
-
-- def assertMultiLineEqual(self, expected, actual):
-+ def assertMultiLineEqual(self, expected, actual, msg=None):
- # This exists in python 2.7, but not previous versions. Use the
- # built-in version if possible.
- if hasattr(unittest.TestCase, "assertMultiLineEqual"):
-- unittest.TestCase.assertMultiLineEqual(self, expected, actual)
-+ unittest.TestCase.assertMultiLineEqual(self, expected, actual, msg)
- else:
-- self.assertTrue(MultiLineEqual(expected, actual))
-+ self.assertTrue(MultiLineEqual(expected, actual), msg)
-
- def assertRaisesWithRegexpMatch(self, exception, regexp, fn, *args, **kwargs):
- try:
-Index: tests/gflags_unittest.py
-===================================================================
---- tests/gflags_unittest.py (revision 40)
-+++ tests/gflags_unittest.py (revision 41)
-@@ -814,7 +814,7 @@ class MultiNumericalFlagsTest(googletest
-
- self.assertRaisesWithRegexpMatch(
- gflags.IllegalFlagValue,
-- 'flag --m_float2=abc: invalid literal for float\(\): abc',
-+ 'flag --m_float2=abc: (invalid literal for float\(\)||could not convert string to float): abc',
- gflags.DEFINE_multi_float, 'm_float2', ['abc'], 'desc')
-
- # Test non-parseable command line values.
-@@ -831,7 +831,7 @@ class MultiNumericalFlagsTest(googletest
- argv = ('./program', '--m_float2=def')
- self.assertRaisesWithRegexpMatch(
- gflags.IllegalFlagValue,
-- 'flag --m_float2=def: invalid literal for float\(\): def',
-+ 'flag --m_float2=def: (invalid literal for float\(\)||could not convert string to float): def',
- FLAGS, argv)
-
-
-
-------------------------------------------------------------------------
diff --git a/dev-python/python-gflags/files/python-gflags-2.0-tests-respect-tmpdir.patch b/dev-python/python-gflags/files/python-gflags-2.0-tests-respect-tmpdir.patch
deleted file mode 100644
index b3ae14e6dd67..000000000000
--- a/dev-python/python-gflags/files/python-gflags-2.0-tests-respect-tmpdir.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Tests try to write to /tmp (sandbox).
-http://code.google.com/p/python-gflags/issues/detail?id=13
-
-From 4a430830e75bfe2228e9d953b12f74a20ec2cb8f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 16 Dec 2012 16:53:24 +0100
-Subject: [PATCH] Use tempfile.mkdtemp() to create temporary directory.
-
-This creates an unique directory, and respects TMPDIR.
----
- tests/gflags_unittest.py | 11 ++++++-----
- 1 file changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/tests/gflags_unittest.py b/tests/gflags_unittest.py
-index 8e948bf..fcddb7b 100755
---- a/tests/gflags_unittest.py
-+++ b/tests/gflags_unittest.py
-@@ -38,6 +38,7 @@ import cStringIO
- import sys
- import os
- import shutil
-+import tempfile
-
- import gflags
- from flags_modules_for_testing import module_foo
-@@ -907,17 +908,16 @@ class LoadFromFlagFileTest(googletest.TestCase):
- flag_values=self.flag_values)
- self.files_to_delete = []
-
-+ # Figure out where to create temporary files
-+ self.tmp_path = tempfile.mkdtemp(prefix='gflags_unittest')
-+
- def tearDown(self):
- self._RemoveTestFiles()
-
- def _SetupTestFiles(self):
- """ Creates and sets up some dummy flagfile files with bogus flags"""
-
-- # Figure out where to create temporary files
-- tmp_path = '/tmp/flags_unittest'
-- if os.path.exists(tmp_path):
-- shutil.rmtree(tmp_path)
-- os.makedirs(tmp_path)
-+ tmp_path = self.tmp_path
-
- try:
- tmp_flag_file_1 = open(tmp_path + '/UnitTestFile1.tst', 'w')
-@@ -973,6 +973,7 @@ class LoadFromFlagFileTest(googletest.TestCase):
- os.remove(file_name)
- except OSError, e_msg:
- print '%s\n, Problem deleting test file' % e_msg
-+ shutil.rmtree(self.tmp_path)
- #end RemoveTestFiles def
-
- def _ReadFlagsFromFiles(self, argv, force_gnu):
---
-1.8.0.2
-