summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-12 11:37:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-13 10:41:57 +0100
commit8c3af2a848b8e2ade51388e8c525d1c9aa6c3a93 (patch)
treef5719e423230898ce596434e712112ecece37af0 /dev-python/python-glanceclient
parentdev-python/python-cinderclient: Remove Python 2 support (diff)
downloadgentoo-8c3af2a848b8e2ade51388e8c525d1c9aa6c3a93.tar.gz
gentoo-8c3af2a848b8e2ade51388e8c525d1c9aa6c3a93.tar.bz2
gentoo-8c3af2a848b8e2ade51388e8c525d1c9aa6c3a93.zip
dev-python/python-glanceclient: Remove Python 2 support
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild4
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild
index 4e68a3f1c255..e23ed64f762c 100644
--- a/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild
+++ b/dev-python/python-glanceclient/python-glanceclient-2.13.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
@@ -68,7 +68,7 @@ python_compile_all() {
python_test() {
testr init
- testr run || die "testsuite failed under python2.7"
+ testr run || die "testsuite failed under ${EPYTHON}"
flake8 tests && einfo "run flake8 over tests folder passed" || die
}
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
index ef647a836996..885408a4fbdc 100644
--- a/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
+++ b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -57,6 +57,6 @@ python_prepare_all() {
python_test() {
testr init
- testr run || die "testsuite failed under python2.7"
+ testr run || die "testsuite failed under ${EPYTHON}"
flake8 tests && einfo "run flake8 over tests folder passed" || die
}