summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2015-11-10 19:10:45 -0800
committerPatrick McLean <chutzpah@gentoo.org>2015-11-10 19:10:45 -0800
commit67939163ee760b619195d04699a5ec9d6c5d0c86 (patch)
tree41b5949e1c1351b7e3a2e18d23afa642ba6974d1 /dev-python/python-iptables/python-iptables-0.10.0.ebuild
parenteutils.eclass: epatch: clarify usage of --dry-run/-f flags when testing #565336 (diff)
downloadgentoo-67939163ee760b619195d04699a5ec9d6c5d0c86.tar.gz
gentoo-67939163ee760b619195d04699a5ec9d6c5d0c86.tar.bz2
gentoo-67939163ee760b619195d04699a5ec9d6c5d0c86.zip
dev-python/python-iptables: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/python-iptables/python-iptables-0.10.0.ebuild')
-rw-r--r--dev-python/python-iptables/python-iptables-0.10.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-iptables/python-iptables-0.10.0.ebuild b/dev-python/python-iptables/python-iptables-0.10.0.ebuild
new file mode 100644
index 000000000000..3c30722be9aa
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+# tests manipulate live iptables rules, so disable them by default
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}