summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-09-27 17:04:18 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-09-27 17:04:50 -0700
commit269373bba471e5d178660dd198463f88a965b4c2 (patch)
tree2033dfd614982ba9d0b4cdaefde6b7cd1ca90735 /dev-python/python-iptables/python-iptables-0.12.0.ebuild
parentwww-client/vivaldi-snapshot: Version bump. (diff)
downloadgentoo-269373bba471e5d178660dd198463f88a965b4c2.tar.gz
gentoo-269373bba471e5d178660dd198463f88a965b4c2.tar.bz2
gentoo-269373bba471e5d178660dd198463f88a965b4c2.zip
dev-python/python-iptables: Version bump to 0.12.0
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python/python-iptables/python-iptables-0.12.0.ebuild')
-rw-r--r--dev-python/python-iptables/python-iptables-0.12.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-iptables/python-iptables-0.12.0.ebuild b/dev-python/python-iptables/python-iptables-0.12.0.ebuild
new file mode 100644
index 000000000000..e294f95ec8fc
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-0.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+# tests manipulate live iptables rules, so disable them by default
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}