summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-05-15 15:08:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-05-15 15:16:20 -0500
commit1801aa4f7993603fab78a72e2d4310ded0e4e8f1 (patch)
treec6ac3e67367a45ca388c765c675e82717ed7bfa5 /dev-python/python-ironicclient
parentdev-python/python-monascaclient: 1.15.0 bump (diff)
downloadgentoo-1801aa4f7993603fab78a72e2d4310ded0e4e8f1.tar.gz
gentoo-1801aa4f7993603fab78a72e2d4310ded0e4e8f1.tar.bz2
gentoo-1801aa4f7993603fab78a72e2d4310ded0e4e8f1.zip
dev-python/python-ironicclient: 2.7.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-ironicclient')
-rw-r--r--dev-python/python-ironicclient/Manifest1
-rw-r--r--dev-python/python-ironicclient/python-ironicclient-2.7.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/python-ironicclient/Manifest b/dev-python/python-ironicclient/Manifest
index 9db500b1e75f..010ec2001a1a 100644
--- a/dev-python/python-ironicclient/Manifest
+++ b/dev-python/python-ironicclient/Manifest
@@ -1,2 +1,3 @@
DIST python-ironicclient-1.17.0.tar.gz 206742 BLAKE2B 8fb92acb02e146916dfebd677ac1c179e78b0c16af80fe59361de6def1435d58466a1b9aef9798a05e0ed2ddc30e860e7da7579c2e6a336ff5f220d41b93b51e SHA512 3a1594d499dbfb508a87e87459308cdeb3eac9987116c8a7a250c5751fc1d4785056033e521ec5d99514a2b6c84362e7576dfec9c4941970422cf2757262c651
DIST python-ironicclient-2.2.1.tar.gz 220436 BLAKE2B b36a5d0b2c297f52a121aa96007ce03556199d7d6139198e39114f2931fd7004bdf76fc5eca369247975bb9eb6d853a2fb4be133976de0ddfeb5767ead6c3c1a SHA512 1827dba991c59cea8a43dd11d0f8f0f1dd6ae41a7f1f28d9d200bac61ae9a4901ac280107fa91a95ebf24072634eadee2e0140f5e1cf5962496f34997815aa04
+DIST python-ironicclient-2.7.1.tar.gz 246190 BLAKE2B c31a439d9175a1915e34988e6e22fe2f05c722925928e30316a3f87023e393a8ee98ca1dbcca19760c009b28c7815478648259865316fac493e1c674cf70fce5 SHA512 654fa4f20b258094d4b05c34f059fa06f12638a210283b6821f6be5acf54bd15a03c73960a7a94d14635a1361370976d86e6b233bd1868c89d9aa82fc1fe7a8f
diff --git a/dev-python/python-ironicclient/python-ironicclient-2.7.1.ebuild b/dev-python/python-ironicclient/python-ironicclient-2.7.1.ebuild
new file mode 100644
index 000000000000..580c14e0457a
--- /dev/null
+++ b/dev-python/python-ironicclient/python-ironicclient-2.7.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Ironic API"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+CRDEPEND="
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ ${CRDEPEND}
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${CRDEPEND}
+"
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/^tempest/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ #rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}