summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 23:24:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:45 -0500
commit9505c0e80ff1222316cce05d74a38d6debed7bab (patch)
treec507051c93646bc3bd0e68273a6485c3c9e65020 /dev-python/python-memcached/python-memcached-1.59.ebuild
parentdev-python/pytz: 2018.9 bump (diff)
downloadgentoo-9505c0e80ff1222316cce05d74a38d6debed7bab.tar.gz
gentoo-9505c0e80ff1222316cce05d74a38d6debed7bab.tar.bz2
gentoo-9505c0e80ff1222316cce05d74a38d6debed7bab.zip
dev-python/python-memcached: 1.59 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-memcached/python-memcached-1.59.ebuild')
-rw-r--r--dev-python/python-memcached/python-memcached-1.59.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-memcached/python-memcached-1.59.ebuild b/dev-python/python-memcached/python-memcached-1.59.ebuild
new file mode 100644
index 000000000000..bb6af4af9326
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.59.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="
+ https://www.tummy.com/Community/software/python-memcached/
+ https://pypi.org/project/python-memcached/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ net-misc/memcached
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+# Tests try to connect to memcached via TCP/IP. Please do not re-enable
+# until you get them all to pass properly while using the UNIX socket
+# only and not even trying to connect to memcached over TCP/IP.
+RESTRICT=test
+
+python_test() {
+ # Note: partial. Needs fixing. Stuff like that.
+
+ cd "${TMPDIR}" || die
+
+ local memcached_opts=( -d -P memcached.pid -s memcached.socket )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+
+ memcached "${memached_opts[@]}" || die
+
+ "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<memcached.pid)" || die
+ rm memcached.pid || die
+}