summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-08 03:18:53 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-08 19:40:15 +0200
commit304ccf83c8464fdd7cb1f3650f7e1d32483a417b (patch)
treeb4f3a6547ad83b9c902149155cf6977c84e7653d /dev-python/python-msrplib/python-msrplib-0.18.0.ebuild
parentdev-python/python-gnutls: initial import of version 2.0.1 (diff)
downloadgentoo-304ccf83c8464fdd7cb1f3650f7e1d32483a417b.tar.gz
gentoo-304ccf83c8464fdd7cb1f3650f7e1d32483a417b.tar.bz2
gentoo-304ccf83c8464fdd7cb1f3650f7e1d32483a417b.zip
dev-python/python-msrplib: initial import of version 0.18.0
Gentoo-Bug: 446194
Diffstat (limited to 'dev-python/python-msrplib/python-msrplib-0.18.0.ebuild')
-rw-r--r--dev-python/python-msrplib/python-msrplib-0.18.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild b/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild
new file mode 100644
index 000000000000..6ca282d5f8e2
--- /dev/null
+++ b/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for MSRP protocol and its relay extension"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/MSRP/python-msrplib-${PV}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/python-application[${PYTHON_USEDEP}]
+ dev-python/python-eventlib[${PYTHON_USEDEP}]
+ dev-python/python-gnutls[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-names[${PYTHON_USEDEP}]
+"