summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-05 14:26:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-05 14:46:20 +0100
commitd1ee402a374133a62c359436f811f216504e6127 (patch)
tree124ba4e7df6eedfb317d7b4d1f4b68230f01607c /dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild
parentmedia-sound/frescobaldi: 2.20.0 version bump (diff)
downloadgentoo-d1ee402a374133a62c359436f811f216504e6127.tar.gz
gentoo-d1ee402a374133a62c359436f811f216504e6127.tar.bz2
gentoo-d1ee402a374133a62c359436f811f216504e6127.zip
dev-python/python-poppler-qt4: 0.24.0 version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild')
-rw-r--r--dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild b/dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild
new file mode 100644
index 000000000000..cab4b8413c80
--- /dev/null
+++ b/dev-python/python-poppler-qt4/python-poppler-qt4-0.24.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python binding for libpoppler-qt4"
+HOMEPAGE="https://github.com/wbsoft/python-poppler-qt4"
+SRC_URI="https://github.com/wbsoft/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler:=[qt4]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/sip:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"