summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-15 08:15:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:21:20 +0200
commita0d32701d706e9be458f3ad8405d57ad2bcec21c (patch)
treeb88554def6b4fc8de797fa0fa30ea3cabe119459 /dev-python/python-prctl
parentdev-python/pytest-cov: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-a0d32701d706e9be458f3ad8405d57ad2bcec21c.tar.gz
gentoo-a0d32701d706e9be458f3ad8405d57ad2bcec21c.tar.bz2
gentoo-a0d32701d706e9be458f3ad8405d57ad2bcec21c.zip
dev-python/python-prctl: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/748678 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-prctl')
-rw-r--r--dev-python/python-prctl/python-prctl-1.7.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/python-prctl/python-prctl-1.7.ebuild b/dev-python/python-prctl/python-prctl-1.7.ebuild
index 853ab34592b5..c9e28fe39342 100644
--- a/dev-python/python-prctl/python-prctl-1.7.ebuild
+++ b/dev-python/python-prctl/python-prctl-1.7.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -15,7 +17,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="sys-libs/libcap"
-
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"