summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-28 17:03:37 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-10-30 00:15:06 +0100
commitfa84ccf43fd4bb629b3953400c518a52185fd528 (patch)
tree80bc21f427d0c85b85145e0f9262422704971c23 /dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild
parentdev-python/python-axolotl: drop old version. (diff)
downloadgentoo-fa84ccf43fd4bb629b3953400c518a52185fd528.tar.gz
gentoo-fa84ccf43fd4bb629b3953400c518a52185fd528.tar.bz2
gentoo-fa84ccf43fd4bb629b3953400c518a52185fd528.zip
dev-python/python-sense-hat: add python3.7 support
Also bumped to EAPI=7 and updated metadata.xml. Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10275 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild')
-rw-r--r--dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..fed87a383669
--- /dev/null
+++ b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raspberry Pi Sense HAT python library"
+HOMEPAGE="https://github.com/RPi-Distro/python-sense-hat"
+SRC_URI="https://github.com/RPi-Distro/python-sense-hat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/rtimulib[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"