summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-01 05:22:45 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-01 05:47:42 +0100
commit2a275e01fb5dd4cb9fa6c3b3209b05fa1e4a4eb5 (patch)
tree82ce02b695b316f417609db152f3e00ffc0fd145 /dev-python/python-slugify
parentdev-python/iminuit: Bump to 2.25.0 (diff)
downloadgentoo-2a275e01fb5dd4cb9fa6c3b3209b05fa1e4a4eb5.tar.gz
gentoo-2a275e01fb5dd4cb9fa6c3b3209b05fa1e4a4eb5.tar.bz2
gentoo-2a275e01fb5dd4cb9fa6c3b3209b05fa1e4a4eb5.zip
dev-python/python-slugify: Bump to 8.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-8.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 218cfcb77b99..73f874b22b0b 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,2 +1,3 @@
DIST python-slugify-8.0.1.gh.tar.gz 13574 BLAKE2B 24fe3dc74f2a867e81bfbb9eac4a1db59a185ddfaf0f2f80cb50d5f06b2061ce28d23ba09ffd214dba26563d1ef37900d016d75dde7a7c35fa756cf49f51b9c2 SHA512 721089244c90f784e49259ee70caa0908d8523c2cf42c8fd57804a73017a815311a9cc9981c1f70a8c2f7cd7e01d77eedf8f9bd3c9d5c55ac4d5f72dbe512b34
DIST python-slugify-8.0.2.gh.tar.gz 13891 BLAKE2B d05e5a5095264a6aec3692dd651f47cc4cfe2580f5bf604531c0c89199d6b350591dfe0238b9ebd025ccf5b6c6e660a75da76d679500efb942f9f9c7aaefba7d SHA512 7de28f06e8f23d46b0be3ede4f1e6fb791f95fae6c7afd94562418a34d3be6a5c4aabc2ef6a8eca353298fd12ea87c71e35e0cd4b6f17b4fee07356c4905a061
+DIST python-slugify-8.0.3.gh.tar.gz 13883 BLAKE2B 0aede0b34124508754625bcf2a4131bfdd5b526424eba23ade4ce927bf6a51dd7232a25c35c19c3eb971eb1b982d39ebc1d4988c1ce2ca3f2db13acc6ce0cb22 SHA512 9dc46117c6d37446b145e11e0a4e40ae2baa9e49a122916e05926db02cf6d2c5c7dced31ac762bf5b0eb941e9dfd95c8dc753a10d6c79a78bb6567544a41321b
diff --git a/dev-python/python-slugify/python-slugify-8.0.3.ebuild b/dev-python/python-slugify/python-slugify-8.0.3.ebuild
new file mode 100644
index 000000000000..53b7da22bd82
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-8.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest