summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 22:23:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 22:51:22 +0100
commitbf70f0ff895944f02b40052a472900cb188d3b66 (patch)
tree73f0ddfd2d6560d964c6cb0f60edccb4f846fe49 /dev-python/python-slugify
parentdev-libs/libgit2: Bump to 1.4.2 (diff)
downloadgentoo-bf70f0ff895944f02b40052a472900cb188d3b66.tar.gz
gentoo-bf70f0ff895944f02b40052a472900cb188d3b66.tar.bz2
gentoo-bf70f0ff895944f02b40052a472900cb188d3b66.zip
dev-python/python-slugify: Bump to 6.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-6.1.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 8ab1a8877e4c..13aeee21859f 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,3 +1,4 @@
DIST python-slugify-5.0.2.tar.gz 11728 BLAKE2B 701fb3f679cd4f714b5c57c14fb8cbfefa5b8268e9c4b877dd1e558e8a7dac325d69519b8e666043b70540908dcb250f561cebf0c5f444f9a3cfae34d97456b1 SHA512 79cdd1d0312c9e34b07dca2e898f177a85b31d3f290403375032ae962df61f3a9c4167f4bdf10f47afd17d544731d6961810f8a081ef615d76d8758c1207e6b7
DIST python-slugify-6.0.1.tar.gz 12184 BLAKE2B ecc39ad73ba4bf68a630c105b22c234c9f8089c5063457c02b21ae5bbe5c021741ce754eabec51bb125ae549274b26f6cf8d986b66ce0ede5a653e70b4528712 SHA512 b97aba9f3b74009a802b1a7bd356d1eb27d239a05d8617c8f0107391e9f09e9a7cb6b45437755a1c86c4eed966e8975f74f6b760e17090d2c56e4db5935c0b69
DIST python-slugify-6.1.0.tar.gz 13279 BLAKE2B ecc51c97638f675573576457f6e6dee14fd2f07b9292e3a32134215887adf945e6b7cc0e373b558c7311a49cfbac1b760191b3e77597a86dac1ea48527d549ac SHA512 4a274d5490bbddb8a600357200d44621cf3304c42a303148156cc732650431e76466099e4eee308e81c881b0da4e39b92146561cfd909a796e153411b22405c9
+DIST python-slugify-6.1.1.tar.gz 13259 BLAKE2B 2f85061775d9e921bf5679ab47d9a5b4fed2d2e1703aa2717e21c1d43fd1b93ef5d7060151bb4b473cd901aef16d3d905d2ca5004ae7bc61e906464bb52494a2 SHA512 2ffe8420b2f0504c57f42bf20aa0145ae521dab8d1bbefcaff1a815aa04377c7eb48eab929890915a9c9632a5c1cac4d3e7e093dcdfdda59f8ecee1ab787cbb7
diff --git a/dev-python/python-slugify/python-slugify-6.1.1.ebuild b/dev-python/python-slugify/python-slugify-6.1.1.ebuild
new file mode 100644
index 000000000000..e06ea5dfd456
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-6.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest