summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-01 22:44:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-01 22:53:31 +0100
commit40a558aaa02e0f303d9a809748746a32f9fa7770 (patch)
tree2dd47965ce8cf09b9a90d8d50f4395faf28fa631 /dev-python/python-socks
parentdev-python/elementpath: Bump to 2.2.0 (diff)
downloadgentoo-40a558aaa02e0f303d9a809748746a32f9fa7770.tar.gz
gentoo-40a558aaa02e0f303d9a809748746a32f9fa7770.tar.bz2
gentoo-40a558aaa02e0f303d9a809748746a32f9fa7770.zip
dev-python/python-socks: Bump to 1.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-1.2.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 2dbde3fdc780..8bc8634d3a40 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,2 +1,3 @@
DIST python-socks-1.2.0.gh.tar.gz 31969 BLAKE2B f967d8100513455533132e7bb276a8f15a8486656c04493cb803640951d2cedaa0b9229386322846ff8992cfd13cf04470b017a615f33392880a4285c9ecd041 SHA512 c5db92b22ef1edef3a22b7ce79975e66f379da2bd8e9a629a15dc2995dfaef3d99d93eaf768ef593b6a7571ad580397290274e319707f36a883a9bcad20434b1
DIST python-socks-1.2.1.gh.tar.gz 32038 BLAKE2B 56f3c885095090f4b3441294977b4af142ace8d2814f5f9b965a68e129baf90a6385dbc7e78463aac2249f97c6d60f03c9ae8b1159e30fcdaaeba00c19831e7b SHA512 8ecc35c51096b1c0312895dcc1169b7f475709f5bdd81572257257cb6bdca00ebcbe9e6b211c66b26ec2dec4dd86051077b7b30279174585428dca0fa7098403
+DIST python-socks-1.2.2.gh.tar.gz 32141 BLAKE2B 51e7c4a2319c4b9680f4568c2dba7f9b64bfb3ec8404dfbb6b30531b9ebeef5cefc95997df7663209909f38583040f3e58c7a9472a75276decef605f5af7c4ba SHA512 27af2da348396e0bd5f6120de7bbb9b89533d3481bb1cbb72668aa28afaa84026fefbd4601b8fd0129d8f5add95b8e00d840d1298eb96b151091f2f64d92dd2f
diff --git a/dev-python/python-socks/python-socks-1.2.2.ebuild b/dev-python/python-socks/python-socks-1.2.2.ebuild
new file mode 100644
index 000000000000..29375e51cbff
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest