summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-31 10:02:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-31 12:14:33 +0200
commit569c67cd3a5da42530fc40561dae50adbce8d425 (patch)
treedd7247b52975c8af48e66383eebc6e21b0f527be /dev-python/python-socks
parentdev-python/httplib2: Bump to 0.19.1 (diff)
downloadgentoo-569c67cd3a5da42530fc40561dae50adbce8d425.tar.gz
gentoo-569c67cd3a5da42530fc40561dae50adbce8d425.tar.bz2
gentoo-569c67cd3a5da42530fc40561dae50adbce8d425.zip
dev-python/python-socks: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-1.2.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 2b2425d2f980..6ac10c9c6606 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,3 +1,4 @@
DIST python-socks-1.2.1.gh.tar.gz 32038 BLAKE2B 56f3c885095090f4b3441294977b4af142ace8d2814f5f9b965a68e129baf90a6385dbc7e78463aac2249f97c6d60f03c9ae8b1159e30fcdaaeba00c19831e7b SHA512 8ecc35c51096b1c0312895dcc1169b7f475709f5bdd81572257257cb6bdca00ebcbe9e6b211c66b26ec2dec4dd86051077b7b30279174585428dca0fa7098403
DIST python-socks-1.2.2.gh.tar.gz 32141 BLAKE2B 51e7c4a2319c4b9680f4568c2dba7f9b64bfb3ec8404dfbb6b30531b9ebeef5cefc95997df7663209909f38583040f3e58c7a9472a75276decef605f5af7c4ba SHA512 27af2da348396e0bd5f6120de7bbb9b89533d3481bb1cbb72668aa28afaa84026fefbd4601b8fd0129d8f5add95b8e00d840d1298eb96b151091f2f64d92dd2f
DIST python-socks-1.2.3.gh.tar.gz 32180 BLAKE2B 340c0a0ff8bfb113e26bb0eaec61f9d57d3e01b5ea045b22ad8dcb48689213ceaf6fafa5901792a1f7333ee1c729c5c44db30d50fbec98bd8f9716eb4e3b6f2b SHA512 1878d7f835a6c97b2577d226363a1f82c8ee4f0fe12931987f7712be98f985e67dce6eee2af8e901756e9bbdd8c667032d7ca37bfa57123c542f8252612dd605
+DIST python-socks-1.2.4.gh.tar.gz 32192 BLAKE2B fa06f9158348292bef874c81623c11a54556db9c36cd7428d7a835428d152f3a4925d59e14d87518dfaae9e6937324e35db99bb5e1000f29fe9caf11fa2f8318 SHA512 6e70d8d98b2901e97250d30b350002944d979356bb6cd7dd4022af420e166076259a7b1aa4845d771243b18ab3f06ee955f07482c527835bb0135f0622d804be
diff --git a/dev-python/python-socks/python-socks-1.2.4.ebuild b/dev-python/python-socks/python-socks-1.2.4.ebuild
new file mode 100644
index 000000000000..29375e51cbff
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest