summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-06 16:36:28 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-06 16:38:18 -0500
commit0fe947962912fa7047d766557fe1f19ff09caed0 (patch)
tree909ce5413fc154facbecca172f2a0fc071778735 /dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild
parentgames-kids/tuxmath: version bump (diff)
downloadgentoo-0fe947962912fa7047d766557fe1f19ff09caed0.tar.gz
gentoo-0fe947962912fa7047d766557fe1f19ff09caed0.tar.bz2
gentoo-0fe947962912fa7047d766557fe1f19ff09caed0.zip
dev-python/python-spidermonkey: add python-spidermonkey-0.0.10
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild')
-rw-r--r--dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild b/dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild
new file mode 100644
index 000000000000..42b640c684a7
--- /dev/null
+++ b/dev-python/python-spidermonkey/python-spidermonkey-0.0.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=(python2_7)
+inherit distutils-r1
+
+DESCRIPTION="JavaScript / Python bridge"
+HOMEPAGE="http://github.com/davisp/python-spidermonkey"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-libs/nspr
+ >=dev-python/nose-0.10.0[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}"
+
+PATCHES=("${FILESDIR}"/${P}-tests.patch)
+
+python_test() {
+ esetup.py test
+}