summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 09:30:54 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 09:30:54 +0100
commitd5e9b0f35895802e187ceb68a26b5aec7d104ba8 (patch)
tree9ad92af4fab79c25452129441ec72a1ff36da546 /dev-python/python-sqlparse/python-sqlparse-0.1.14.ebuild
parentdev-python/click: Build docs using python2 (diff)
downloadgentoo-d5e9b0f35895802e187ceb68a26b5aec7d104ba8.tar.gz
gentoo-d5e9b0f35895802e187ceb68a26b5aec7d104ba8.tar.bz2
gentoo-d5e9b0f35895802e187ceb68a26b5aec7d104ba8.zip
dev-python/python-sqlparse: Fix doc building
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=572742 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-sqlparse/python-sqlparse-0.1.14.ebuild')
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.1.14.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.1.14.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.1.14.ebuild
index 5a3edd7e42fd..cfc6770b7e25 100644
--- a/dev-python/python-sqlparse/python-sqlparse-0.1.14.ebuild
+++ b/dev-python/python-sqlparse/python-sqlparse-0.1.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,8 +20,11 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linu
LICENSE="BSD-2"
IUSE="doc test"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-cov[${PYTHON_USEDEP}]
@@ -31,6 +34,10 @@ DISTUTILS_IN_SOURCE_BUILD=1
S="${WORKDIR}"/${P#python-}
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_compile_all() {
use doc && emake -C docs html
}