summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-24 20:45:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-24 20:48:38 +0100
commit5a618765b0d0f12acaad54efe3587bcb00c9ce74 (patch)
tree24c715e084bff295993a5ff0eefb540ea64c5a15 /dev-python/python-sshpubkeys
parentdev-python/cx_Freeze: Remove python@ from maintainers (diff)
downloadgentoo-5a618765b0d0f12acaad54efe3587bcb00c9ce74.tar.gz
gentoo-5a618765b0d0f12acaad54efe3587bcb00c9ce74.tar.bz2
gentoo-5a618765b0d0f12acaad54efe3587bcb00c9ce74.zip
dev-python/python-sshpubkeys: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-sshpubkeys')
-rw-r--r--dev-python/python-sshpubkeys/Manifest1
-rw-r--r--dev-python/python-sshpubkeys/python-sshpubkeys-3.2.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-sshpubkeys/Manifest b/dev-python/python-sshpubkeys/Manifest
index 90314609466a..d768ce355e01 100644
--- a/dev-python/python-sshpubkeys/Manifest
+++ b/dev-python/python-sshpubkeys/Manifest
@@ -1 +1,2 @@
DIST python-sshpubkeys-3.1.0.tar.gz 55289 BLAKE2B bf1836c173b542f0edc8dc0635a1f5bf109ef95936ffbabf6bbb79ac3bc34c10a769733d622c338b1f3a87d5be84b89ea9779f7fa293cad706f364d5e8867afc SHA512 4f07cb7bd2b1839a63bff842660499cee816e8675d8fde1e84ee567e354c82677a69e539b99505c6d1c5e0e7a5962a36175eb0cfcc763886a33952d2346c3405
+DIST python-sshpubkeys-3.2.1.tar.gz 57872 BLAKE2B b3a5a3aa719d3fac4608e6f43fcee4d3377baad73d0acc451fb4fc6c8a3895f5288607b68a2b3b3b65d86210d28a22e0c83cb8b3758eeaf88969ae803568efcf SHA512 10e593f5250e14e91b6212e29831c8575cf1d335e9db5c8241a3d3614793aacd2ddc609b07c4bd4bed99900fffb5c40562daff24c6a0715927ef1f75a484273e
diff --git a/dev-python/python-sshpubkeys/python-sshpubkeys-3.2.1.ebuild b/dev-python/python-sshpubkeys/python-sshpubkeys-3.2.1.ebuild
new file mode 100644
index 000000000000..c2a98bb36685
--- /dev/null
+++ b/dev-python/python-sshpubkeys/python-sshpubkeys-3.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="OpenSSH public key parser for Python"
+HOMEPAGE="
+ https://pypi.org/project/sshpubkeys/
+ https://github.com/ojarva/python-sshpubkeys"
+SRC_URI="
+ https://github.com/ojarva/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest