summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-05 01:54:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-05 01:55:30 +0100
commit5ec91203bf8ec6e1fafff13d7b34e9318bdc10cf (patch)
treebcde2a8ea3c0dda20c7198115617f290a2c4056c /dev-python/python-sshpubkeys
parentdev-python/dulwich: Bump to 0.20.18 (diff)
downloadgentoo-5ec91203bf8ec6e1fafff13d7b34e9318bdc10cf.tar.gz
gentoo-5ec91203bf8ec6e1fafff13d7b34e9318bdc10cf.tar.bz2
gentoo-5ec91203bf8ec6e1fafff13d7b34e9318bdc10cf.zip
dev-python/python-sshpubkeys: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-sshpubkeys')
-rw-r--r--dev-python/python-sshpubkeys/Manifest1
-rw-r--r--dev-python/python-sshpubkeys/python-sshpubkeys-3.3.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-sshpubkeys/Manifest b/dev-python/python-sshpubkeys/Manifest
index e80cefb56254..31428f426482 100644
--- a/dev-python/python-sshpubkeys/Manifest
+++ b/dev-python/python-sshpubkeys/Manifest
@@ -1,3 +1,4 @@
DIST python-sshpubkeys-3.1.0.tar.gz 55289 BLAKE2B bf1836c173b542f0edc8dc0635a1f5bf109ef95936ffbabf6bbb79ac3bc34c10a769733d622c338b1f3a87d5be84b89ea9779f7fa293cad706f364d5e8867afc SHA512 4f07cb7bd2b1839a63bff842660499cee816e8675d8fde1e84ee567e354c82677a69e539b99505c6d1c5e0e7a5962a36175eb0cfcc763886a33952d2346c3405
DIST python-sshpubkeys-3.2.1.tar.gz 57872 BLAKE2B b3a5a3aa719d3fac4608e6f43fcee4d3377baad73d0acc451fb4fc6c8a3895f5288607b68a2b3b3b65d86210d28a22e0c83cb8b3758eeaf88969ae803568efcf SHA512 10e593f5250e14e91b6212e29831c8575cf1d335e9db5c8241a3d3614793aacd2ddc609b07c4bd4bed99900fffb5c40562daff24c6a0715927ef1f75a484273e
DIST python-sshpubkeys-3.3.0.tar.gz 57904 BLAKE2B b716f91f99539a27574842687ca71b9eef4f715a667931576a94094687a6dd9bbb2ad50826fe2a4d7f21d546c4dd1e33daa815128e62e2446ade30218c3b42a2 SHA512 41314001e6f32a6286927833e64622c45bc5c55729722351dbb2305919a5b44fe74e528988a3fad672595eb2e8da7db225ad7ea6395aa14dc5abdc38187a600c
+DIST python-sshpubkeys-3.3.1.tar.gz 57896 BLAKE2B 3212ea0c38377255258a831cc942f71c0b0efb040ba8ca3283200b638dcae7a31ad5763ae0de4f51a7ae0c3f0a1b83ca6db96f00384ecd1e1e3a369028e4ed41 SHA512 8a59e73eddd795a71b64fc7433292ca03a9f447a13c8ef40d68fc599776c37f5e4a1fdbbf2f2ab00b0091a513e2412f213f6a21474ae0784af2df9a7107a2ed6
diff --git a/dev-python/python-sshpubkeys/python-sshpubkeys-3.3.1.ebuild b/dev-python/python-sshpubkeys/python-sshpubkeys-3.3.1.ebuild
new file mode 100644
index 000000000000..c2a98bb36685
--- /dev/null
+++ b/dev-python/python-sshpubkeys/python-sshpubkeys-3.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="OpenSSH public key parser for Python"
+HOMEPAGE="
+ https://pypi.org/project/sshpubkeys/
+ https://github.com/ojarva/python-sshpubkeys"
+SRC_URI="
+ https://github.com/ojarva/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest