summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-stdnum
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest2
-rw-r--r--dev-python/python-stdnum/metadata.xml17
-rw-r--r--dev-python/python-stdnum/python-stdnum-0.9.ebuild23
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.1.ebuild28
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
new file mode 100644
index 000000000000..440a5204af0c
--- /dev/null
+++ b/dev-python/python-stdnum/Manifest
@@ -0,0 +1,2 @@
+DIST python-stdnum-0.9.tar.gz 136636 SHA256 c25bbdc6d8fb9d82e4d4d3c72545cff56eb8dd4389162e4ee415c3c7218136e6 SHA512 c9870ad116c2c08b123b7b01cc229a1f9d3f3e15da3ba75bdf5da8bee2a854474f6ddd7464c2d662559fedf272ea13a3549ed79a4636ddc1d733a47ea11ae058 WHIRLPOOL 3e124851b81e9cf8212994a8720b1b4994883d8175198fa1a0ee907dc989e4f5edd28c6e0f71c1a2b0df3987499f05f25405bfaa969e93c47c17fda7c4dc59a1
+DIST python-stdnum-1.1.tar.gz 205495 SHA256 66ee880bfd60cadeca667eba6f29803b6712eb554a2d19cfb8e1ea86ce42df35 SHA512 b066b5cd4b04b70b52850942489f28165a833d2e29fe16eeec9b93e395f19742eaf2edc3cdbb31972e8ffd7ad46b189a186c3ed93bd91ab90e829681f54cf1f4 WHIRLPOOL 79c908885b0d3f89a300511d04f3283fcbaec02938ce763a263f40e6febef62c607ee241cc664bdbfc98176505b58ac69820fea717455bef3f17f5e93dcae8a9
diff --git a/dev-python/python-stdnum/metadata.xml b/dev-python/python-stdnum/metadata.xml
new file mode 100644
index 000000000000..3f5b90a8a722
--- /dev/null
+++ b/dev-python/python-stdnum/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <longdescription lang="en">
+ A module to handle standardized numbers and codes
+ </longdescription>
+ <use>
+ <flag name="vies">Enable VIES</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">python-stdnum</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-stdnum/python-stdnum-0.9.ebuild b/dev-python/python-stdnum/python-stdnum-0.9.ebuild
new file mode 100644
index 000000000000..9d0c6d1dbf66
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-0.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+DEPEND="dev-python/setuptools
+ vies? ( dev-python/suds )"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog NEWS README )
diff --git a/dev-python/python-stdnum/python-stdnum-1.1.ebuild b/dev-python/python-stdnum/python-stdnum-1.1.ebuild
new file mode 100644
index 000000000000..364541aa3435
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( dev-python/suds )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests || die
+}