summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-urljr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-urljr')
-rw-r--r--dev-python/python-urljr/Manifest1
-rw-r--r--dev-python/python-urljr/files/python-urljr-1.0.1-gentoo-test_fetchers.patch11
-rw-r--r--dev-python/python-urljr/metadata.xml6
-rw-r--r--dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild28
4 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-urljr/Manifest b/dev-python/python-urljr/Manifest
new file mode 100644
index 000000000000..752b9a593cc4
--- /dev/null
+++ b/dev-python/python-urljr/Manifest
@@ -0,0 +1 @@
+DIST python-urljr-1.0.1.tar.gz 16570 SHA256 723bc0c1b58d34ca41b9d3ec57ba5e9cb16283e49d8ac152d455476cc249bff6 SHA512 fff9e5f557ff8fa88e122f535134320043f9a14fd8048234bef762af666f4c088d50c6bc8dd3d173154e80eb8e076f0fb6749e39dd9c6f88c7ab763314dad0ad WHIRLPOOL 5919e01df94373ad98b3fa2622ddf45b9f7abeadbc8b8ace0dc4f8b38ef5be85b43c696cf349f815f6273811bb65940b339667aefcccba8ae9aff5364afb2a20
diff --git a/dev-python/python-urljr/files/python-urljr-1.0.1-gentoo-test_fetchers.patch b/dev-python/python-urljr/files/python-urljr-1.0.1-gentoo-test_fetchers.patch
new file mode 100644
index 000000000000..5a451e4a5600
--- /dev/null
+++ b/dev-python/python-urljr/files/python-urljr-1.0.1-gentoo-test_fetchers.patch
@@ -0,0 +1,11 @@
+--- urljr/test/test_fetchers.py.orig 2007-05-31 09:16:31.000000000 -0700
++++ urljr/test/test_fetchers.py 2007-05-31 09:17:47.000000000 -0700
+@@ -8,6 +8,8 @@
+ # XXX: make these separate test cases
+
+ def failUnlessResponseExpected(expected, actual):
++ expected.final_url = expected.final_url.replace("localhost", "127.0.0.1")
++ actual.final_url = actual.final_url.replace("localhost", "127.0.0.1")
+ assert expected.final_url == actual.final_url
+ assert expected.status == actual.status
+ assert expected.body == actual.body
diff --git a/dev-python/python-urljr/metadata.xml b/dev-python/python-urljr/metadata.xml
new file mode 100644
index 000000000000..7b4c64f109b6
--- /dev/null
+++ b/dev-python/python-urljr/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>JanRain's URL Utilities</longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild b/dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..a966ca2fee7e
--- /dev/null
+++ b/dev-python/python-urljr/python-urljr-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="JanRain's URL Utilities"
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
+SRC_URI="http://www.openidenabled.com/resources/downloads/python-openid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl test"
+
+RDEPEND="curl? ( >=dev-python/pycurl-7.15.1[${PYTHON_USEDEP}] )"
+DEPEND=""
+
+REQUIRED_USE="test? ( curl )"
+# test fails if it finds 'localhost' instead of '127.0.0.1'
+PATCHES=( "${FILESDIR}/${P}-gentoo-test_fetchers.patch" )
+
+python_test() {
+ PYTHONPATH=. "${PYTHON}" admin/runtests || die "tests failed"
+}