summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-13 14:22:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-13 14:24:14 +0200
commit56a2f42fd91994056b8ea403a2953ecd0aa199ae (patch)
treeb3f093b2ad24d00a850109df84367797b0bf5418 /dev-python/python_orocos_kdl
parentdev-util/catkin: add py39 (diff)
downloadgentoo-56a2f42fd91994056b8ea403a2953ecd0aa199ae.tar.gz
gentoo-56a2f42fd91994056b8ea403a2953ecd0aa199ae.tar.bz2
gentoo-56a2f42fd91994056b8ea403a2953ecd0aa199ae.zip
dev-python/python_orocos_kdl: add py39
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/python_orocos_kdl')
-rw-r--r--dev-python/python_orocos_kdl/files/0001-Declare-assignment-operator-private-for-SIP-Closes-2.patch12
-rw-r--r--dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0-r1.ebuild14
-rw-r--r--dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild14
3 files changed, 20 insertions, 20 deletions
diff --git a/dev-python/python_orocos_kdl/files/0001-Declare-assignment-operator-private-for-SIP-Closes-2.patch b/dev-python/python_orocos_kdl/files/0001-Declare-assignment-operator-private-for-SIP-Closes-2.patch
index b02f18747cfe..6c8d93ed62e7 100644
--- a/dev-python/python_orocos_kdl/files/0001-Declare-assignment-operator-private-for-SIP-Closes-2.patch
+++ b/dev-python/python_orocos_kdl/files/0001-Declare-assignment-operator-private-for-SIP-Closes-2.patch
@@ -16,10 +16,10 @@ operator. This PR makes this known to SIP as well.
python_orocos_kdl/PyKDL/kinfam.sip | 29 ++++++++++++++++++++++++++++
2 files changed, 32 insertions(+)
-diff --git a/python_orocos_kdl/PyKDL/dynamics.sip b/python_orocos_kdl/PyKDL/dynamics.sip
+diff --git a/PyKDL/dynamics.sip b/python_orocos_kdl/PyKDL/dynamics.sip
index e0096dd..36f833c 100644
---- a/python_orocos_kdl/PyKDL/dynamics.sip
-+++ b/python_orocos_kdl/PyKDL/dynamics.sip
+--- a/PyKDL/dynamics.sip
++++ b/PyKDL/dynamics.sip
@@ -72,4 +72,7 @@ public:
int JntToCoriolis(const JntArray &q, const JntArray &q_dot, JntArray &coriolis);
int JntToMass(const JntArray &q, JntSpaceInertiaMatrix& H);
@@ -28,10 +28,10 @@ index e0096dd..36f833c 100644
+private:
+ ChainDynParam& operator=(const ChainDynParam&);
};
-diff --git a/python_orocos_kdl/PyKDL/kinfam.sip b/python_orocos_kdl/PyKDL/kinfam.sip
+diff --git a/PyKDL/kinfam.sip b/python_orocos_kdl/PyKDL/kinfam.sip
index d87fd00..e87ceb8 100644
---- a/python_orocos_kdl/PyKDL/kinfam.sip
-+++ b/python_orocos_kdl/PyKDL/kinfam.sip
+--- a/PyKDL/kinfam.sip
++++ b/PyKDL/kinfam.sip
@@ -344,6 +344,9 @@ public:
ChainFkSolverPos_recursive(const Chain& chain);
virtual int JntToCart(const JntArray& q_in, Frame& p_out,int segmentNr=-1);
diff --git a/dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0-r1.ebuild b/dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0-r1.ebuild
index a1f82a9e03ef..dbb79e0ff7f7 100644
--- a/dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0-r1.ebuild
+++ b/dev-python/python_orocos_kdl/python_orocos_kdl-1.4.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/orocos/orocos_kinematics_dynamics"
fi
-inherit ${SCM} python-r1 cmake-utils
+inherit ${SCM} python-r1 cmake
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
@@ -41,19 +41,19 @@ else
fi
src_configure() {
- python_foreach_impl cmake-utils_src_configure
+ python_foreach_impl cmake_src_configure
}
src_compile() {
- python_foreach_impl cmake-utils_src_compile
+ python_foreach_impl cmake_src_compile
}
src_test() {
- python_foreach_impl cmake-utils_src_test
+ python_foreach_impl cmake_src_test
}
src_install() {
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
# Need to have package.xml in our custom gentoo path
insinto /usr/share/ros_packages/${PN}
diff --git a/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild b/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild
index 06e204006f9f..228748e30394 100644
--- a/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild
+++ b/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/orocos/orocos_kinematics_dynamics"
fi
-inherit ${SCM} python-r1 cmake-utils
+inherit ${SCM} python-r1 cmake
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
@@ -40,19 +40,19 @@ else
fi
src_configure() {
- python_foreach_impl cmake-utils_src_configure
+ python_foreach_impl cmake_src_configure
}
src_compile() {
- python_foreach_impl cmake-utils_src_compile
+ python_foreach_impl cmake_src_compile
}
src_test() {
- python_foreach_impl cmake-utils_src_test
+ python_foreach_impl cmake_src_test
}
src_install() {
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
# Need to have package.xml in our custom gentoo path
insinto /usr/share/ros_packages/${PN}